aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorPetter Mabäcker <petter@technux.se>2015-01-06 22:29:04 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-23 11:35:25 +0000
commit9d220b1bfe4589736604dd5a7129e3699377d830 (patch)
treeb1f6812ef2cdd5f93e3e8b5c8bb9c025c2cf00aa /meta/recipes-devtools
parentdd7be09318b55a69cb8636e86d2af6e6b8140b31 (diff)
downloadopenembedded-core-contrib-9d220b1bfe4589736604dd5a7129e3699377d830.tar.gz
meta: set proper S value
After removal of auto-creating S we must ensure that all recipes are using a proper value for S. Fix all recipes that only need to set S equals to WORKDIR. [YOCTO #5627] Signed-off-by: Petter Mabäcker <petter@technux.se>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/opkg/opkg-collateral.bb2
-rw-r--r--meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb2
2 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg-collateral.bb b/meta/recipes-devtools/opkg/opkg-collateral.bb
index 3825ffb064..0cf6b8be40 100644
--- a/meta/recipes-devtools/opkg/opkg-collateral.bb
+++ b/meta/recipes-devtools/opkg/opkg-collateral.bb
@@ -8,6 +8,8 @@ SRC_URI = "file://opkg.conf.comments \
file://dest \
file://src "
+S = "${WORKDIR}"
+
OPKGLIBDIR = "${localstatedir}/lib"
do_compile () {
cat ${WORKDIR}/opkg.conf.comments >${WORKDIR}/opkg.conf
diff --git a/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb b/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
index 64f85c262d..d126132a87 100644
--- a/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
+++ b/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
@@ -9,6 +9,8 @@ SRC_URI = "file://run-postinsts \
file://run-postinsts.init \
file://run-postinsts.service"
+S = "${WORKDIR}"
+
inherit allarch systemd update-rc.d
INITSCRIPT_NAME = "run-postinsts"