aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-05-13 10:54:26 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-29 13:42:10 +0100
commitebe73f25c68780d1a5f593e7b842312ac738b324 (patch)
treeca2beb8b2411a52dd029a7620747ecf2d75b21ce /meta/recipes-devtools
parentbe4aef60e6da08b77a5c1fbbf783305bee9f96ae (diff)
downloadopenembedded-core-contrib-ebe73f25c68780d1a5f593e7b842312ac738b324.tar.gz
gdb: add PACKAGECONFIG for babeltrace
Add PACKAGECONFIG for 'babeltrace' so that we don't have the implicit dependency which might lead to problems when building images. As an example of showing what problem we might have without this patch, see the following steps which would lead to a failure. 1. IMAGE_INSTALL_append = " gdb" 2. bitbake babeltrace 3. bitbake gdb 4. bitbake babeltrace -ccleansstate 5. bitbake core-image-minimal The rootfs process would fail with the following error message. error: Can't install gdb-7.7-r0@i586: no package provides babeltrace >= 1.2.1+git0+66c2a20b43 (From OE-Core rev: 3c34d9391136b09bc2e7b0bda6cdc96507845c4b) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.6.2.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.6.2.bb b/meta/recipes-devtools/gdb/gdb_7.6.2.bb
index e86447121b..7e8a4fdbde 100644
--- a/meta/recipes-devtools/gdb/gdb_7.6.2.bb
+++ b/meta/recipes-devtools/gdb/gdb_7.6.2.bb
@@ -5,6 +5,7 @@ inherit python-dir
PACKAGECONFIG ??= ""
PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python"
+PACKAGECONFIG[babeltrace] = "--with-babeltrace,--without-babeltrace,babeltrace"
do_configure_prepend() {
if [ -n "${@base_contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then