aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorMike Crowe <mac@mcrowe.com>2014-04-08 14:51:22 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-08 17:44:55 +0100
commiteaf176eaabb4c558ad76512b30b28ec97fd90bc6 (patch)
tree3d6d49050abc718e3e7a7c1d06dca6b92adbb340 /meta/recipes-devtools
parent9db71fa03b9d5f5307b2d09e7aa89f46f622aa09 (diff)
downloadopenembedded-core-contrib-eaf176eaabb4c558ad76512b30b28ec97fd90bc6.tar.gz
cmake: Improve method for not building ccmake
In commit 4bee0a93ed985b38c6b4eb605d8e16f5d7c82d51 I introduced an unnecessary patch to do something that can easily be done without patching. The argument to disable building ccmake can be passed to configure provided it is preceded by "--". Signed-off-by: Mike Crowe <mac@mcrowe.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb6
-rw-r--r--meta/recipes-devtools/cmake/cmake.inc5
-rw-r--r--meta/recipes-devtools/cmake/cmake/disable-bootstrap-cursesdialog.patch17
3 files changed, 9 insertions, 19 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb b/meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb
index d032cb97e0..638c074d6a 100644
--- a/meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb
+++ b/meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb
@@ -6,8 +6,12 @@ DEPENDS += "bzip2-native zlib-native"
SRC_URI += "\
file://cmlibarchive-disable-ext2fs.patch \
- file://disable-bootstrap-cursesdialog.patch \
"
SRC_URI[md5sum] = "17c6513483d23590cbce6957ec6d1e66"
SRC_URI[sha256sum] = "8c6574e9afabcb9fc66f463bb1f2f051958d86c85c37fccf067eb1a44a120e5e"
+
+# Disable ccmake since we don't depend on ncurses
+CMAKE_EXTRACONF = "\
+ -DBUILD_CursesDialog=0 \
+"
diff --git a/meta/recipes-devtools/cmake/cmake.inc b/meta/recipes-devtools/cmake/cmake.inc
index a0fcf490ec..8592a23046 100644
--- a/meta/recipes-devtools/cmake/cmake.inc
+++ b/meta/recipes-devtools/cmake/cmake.inc
@@ -43,6 +43,9 @@ do_configure_prepend() {
sed -i 's/^find_package(Qt5Widgets QUIET)/#find_package(Qt5Widgets QUIET)/g' ${S}/Source/QtDialog/CMakeLists.txt
}
+# Extra flags to pass to cmake invoked by bootstrap
+CMAKE_EXTRACONF = ""
+
do_configure () {
- ./configure --prefix=${prefix}
+ ./configure --prefix=${prefix} -- ${CMAKE_EXTRACONF}
}
diff --git a/meta/recipes-devtools/cmake/cmake/disable-bootstrap-cursesdialog.patch b/meta/recipes-devtools/cmake/cmake/disable-bootstrap-cursesdialog.patch
deleted file mode 100644
index 9d378fb24c..0000000000
--- a/meta/recipes-devtools/cmake/cmake/disable-bootstrap-cursesdialog.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Disable building CursesDialog so that cmake-native doesn't have to
-depend on ncurses-native.
-
-Upstream-status: Inappropriate [disable feature]
-
-Signed-off-by: Mike Crowe <mac@mcrowe.com>
-
---- cmake-2.8.12.2/bootstrap~ 2014-01-16 17:15:09.000000000 +0000
-+++ cmake-2.8.12.2/bootstrap 2014-04-01 21:27:23.841996822 +0100
-@@ -1578,6 +1578,7 @@ export MAKE
-
- # Run bootstrap CMake to configure real CMake
- cmake_options="-DCMAKE_BOOTSTRAP=1"
-+cmake_options="${cmake_options} -DBUILD_CursesDialog=0"
- if [ -n "${cmake_verbose}" ]; then
- cmake_options="${cmake_options} -DCMAKE_VERBOSE_MAKEFILE=1"
- fi