aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/valgrind
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-12-09 10:52:48 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-12 23:31:43 +0000
commit652c5ae2c8317dcd93ada409365eeb56ceb54d0b (patch)
treebbd835ae48c95ed647d4d98a9c4ee178026216fe /meta/recipes-devtools/valgrind
parent4a839105c7166390aed5f963918c03dbebf22ab5 (diff)
downloadopenembedded-core-contrib-652c5ae2c8317dcd93ada409365eeb56ceb54d0b.tar.gz
valgrind: import Debian link_tool patch for MIPS
Without this patch, valgrind 3.10.1 fails to run on MIPS: | root@bcm97425vms:~# valgrind /bin/ls | valgrind: mmap(0x400000, 700416) failed in UME with error 22 (Invalid argument). | valgrind: this can be caused by executables with very large text, data or bss segments. Original Debian bug report: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=777704 Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/valgrind')
-rw-r--r--meta/recipes-devtools/valgrind/valgrind/11_mips-link-tool.patch37
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.10.1.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind/11_mips-link-tool.patch b/meta/recipes-devtools/valgrind/valgrind/11_mips-link-tool.patch
new file mode 100644
index 0000000000..ecb33b8cb3
--- /dev/null
+++ b/meta/recipes-devtools/valgrind/valgrind/11_mips-link-tool.patch
@@ -0,0 +1,37 @@
+Debian fix for MIPS: mmap(0x400000, 32768) failed in UME with error 22 (Invalid argument)
+
+ https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=777704
+
+Upstream-Status: Pending
+
+Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
+
+
+Description: Disable the MIPS linker workarounds when using -Ttext-section
+Origin: vendor
+Bug-Debian: http://bugs.debian.org/777704
+Author: James Cowgill <james410@cowgill.org.uk>
+Last-Update: 2015-04-25
+
+--- a/coregrind/link_tool_exe_linux.in
++++ b/coregrind/link_tool_exe_linux.in
+@@ -76,12 +76,13 @@
+ my $arch = substr($x, 0, index($x, "'"));
+
+ my $extra_args;
+-if (($arch eq 'mips') || ($arch eq 'mipsel')
+- || ($arch eq 'mipsisa32r2el')) {
+- $extra_args = "-static -Wl,--section-start=.reginfo=$ala";
+-} elsif (($arch eq 'mips64') || ($arch eq 'mips64el') ||
+- ($arch eq 'mipsisa64el')) {
+- $extra_args = "-static -Wl,--section-start=.MIPS.options=$ala";
++if ($arch =~ /^mips/ && "@FLAG_T_TEXT@" eq '-Ttext') {
++ # We only need to use the special mips options when using -Ttext
++ if ($arch =~ /^mips(64|isa64)/) {
++ $extra_args = "-static -Wl,--section-start=.MIPS.options=$ala";
++ } else {
++ $extra_args = "-static -Wl,--section-start=.reginfo=$ala";
++ }
+ } else {
+ $extra_args = "-static -Wl,@FLAG_T_TEXT@=$ala";
+ }
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.10.1.bb b/meta/recipes-devtools/valgrind/valgrind_3.10.1.bb
index 86ba979ea8..c386a19e88 100644
--- a/meta/recipes-devtools/valgrind/valgrind_3.10.1.bb
+++ b/meta/recipes-devtools/valgrind/valgrind_3.10.1.bb
@@ -26,6 +26,7 @@ SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \
file://pass-maltivec-only-if-it-supported.patch \
file://run-ptest \
file://0001-valgrind-Enable-rt_sigpending-syscall-on-ppc64-linux.patch \
+ file://11_mips-link-tool.patch \
"
SRC_URI[md5sum] = "60ddae962bc79e7c95cfc4667245707f"