summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/valgrind
diff options
context:
space:
mode:
authorRandy MacLeod <Randy.MacLeod@windriver.com>2019-05-13 23:57:16 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-15 17:52:49 +0100
commit7fc21775e62fddd6620d49a6cf00ca914ba6b4ba (patch)
tree871e0d8712a787c337e766d005b099df12dbfe44 /meta/recipes-devtools/valgrind
parent38cc663b69ec96ae1470f040f7dcb05e816deb2e (diff)
downloadopenembedded-core-contrib-7fc21775e62fddd6620d49a6cf00ca914ba6b4ba.tar.gz
valgrind: fix call/cachegrind ptests
Use the *_annotate executables from ${bindir} Actually install cachegrind/tests/a.c since it is used by the call/cachegrind/tests/ann[12].vgtest files. With this change and the previous commits, the ptest results on qemux86-64 when invoked with: runqemu qemux86 kvm nographic slirp qemuparams="-m 2048" are: === Test Summary === TOTAL: 159 PASSED: 149 FAILED: 1 SKIPPED: 9 Only drd/tests/pth_detached3 remains to be fixed. Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/valgrind')
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.15.0.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb
index 4ab2952fde..ae3498f551 100644
--- a/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb
+++ b/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb
@@ -157,6 +157,8 @@ do_install_ptest() {
cd $saved_dir
done
+ # Hide then restore a.c that is used by ann[12].vgtest in call/cachegrind
+ mv ${D}${PTEST_PATH}/cachegrind/tests/a.c ${D}${PTEST_PATH}/cachegrind/tests/a_c
# clean out build artifacts before building the rpm
find ${D}${PTEST_PATH} \
\( -name "Makefile*" \
@@ -165,6 +167,14 @@ do_install_ptest() {
-o -name "*.S" \
-o -name "*.h" \) \
-exec rm {} \;
+ mv ${D}${PTEST_PATH}/cachegrind/tests/a_c ${D}${PTEST_PATH}/cachegrind/tests/a.c
+
+ # find *_annotate in ${bindir} for yocto build
+ sed -i s:\.\./\.\./cachegrind/cg_annotate:${bindir}/cg_annotate: ${D}${PTEST_PATH}/cachegrind/tests/ann1.vgtest
+ sed -i s:\.\./\.\./cachegrind/cg_annotate:${bindir}/cg_annotate: ${D}${PTEST_PATH}/cachegrind/tests/ann2.vgtest
+
+ sed -i s:\.\./\.\./callgrind/callgrind_annotate:${bindir}/callgrind_annotate: ${D}${PTEST_PATH}/callgrind/tests/ann1.vgtest
+ sed -i s:\.\./\.\./callgrind/callgrind_annotate:${bindir}/callgrind_annotate: ${D}${PTEST_PATH}/callgrind/tests/ann2.vgtest
# needed by massif tests
cp ${B}/massif/ms_print ${D}${PTEST_PATH}/massif/ms_print