summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb
diff options
context:
space:
mode:
authorRandy MacLeod <Randy.MacLeod@windriver.com>2019-09-10 17:41:36 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-16 23:02:44 +0100
commit09cfb218cbd2416b179721bc5198d24ee5b61a44 (patch)
tree87aa0ed859b539e4556d3a6d1e2e236fa1028a06 /meta/recipes-devtools/valgrind/valgrind_3.15.0.bb
parent997d91f608ca5f866f9800c52a4d2ebbbce70cd2 (diff)
downloadopenembedded-core-contrib-09cfb218cbd2416b179721bc5198d24ee5b61a44.tar.gz
valgrind: disable 256 ptests for aarch64
On qemuarm64 systems, about half of the valgrind tests fail and often result in defunct processes, eg: root 819 818 25 00:12 pts/0 00:01:52 /usr/bin/valgrind --command-line-only=yes --memcheck:leak-check=no --tool=memcheck -q --track-origins= root 861 420 0 00:13 pts/0 00:00:00 [sh] <defunct> Eventually these processes use so much memory that the out of memory killer runs. Hide the tests that fail as a horrid work-around until the root cause has been resolved since this at least allows the ptest run to complete. This work-around is done in the run-ptest script using a sorted list of tests so that they can be easily restored one by one without a rebuild during testing. With core-image-minimal on qemuarm64: Recipe | Passed | Failed | Skipped | Time(s) valgrind | 333 | 49 | 17 | 7637 (From OE-Core rev: 208023f8fcbf4aee34544a80f962ae25f25ffb8d) Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/valgrind/valgrind_3.15.0.bb')
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.15.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb
index 6d47b6d01d..63f972945d 100644
--- a/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb
+++ b/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb
@@ -15,6 +15,7 @@ SRC_URI = "https://sourceware.org/pub/valgrind/valgrind-${PV}.tar.bz2 \
file://fixed-perl-path.patch \
file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
file://run-ptest \
+ file://remove-for-aarch64 \
file://0004-Fix-out-of-tree-builds.patch \
file://0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch \
file://0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch \
@@ -165,6 +166,7 @@ do_install_ptest() {
# The scripts reference config.h so add it to the top ptest dir.
cp ${B}/config.h ${D}${PTEST_PATH}
+ install -D ${WORKDIR}/remove-for-aarch64 ${D}${PTEST_PATH}
# Add an executable need by none/tests/bigcode
mkdir ${D}${PTEST_PATH}/perf