aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/unfs-server
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2011-10-05 10:26:30 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-10 09:54:02 +0100
commit3b1346c607c41a2d592c48594457c32153cb2314 (patch)
tree5c15d2d971e63ac5e542ef1f0ff54600b6aff4fc /meta/recipes-devtools/unfs-server
parentb0c111fd15be671be77ce886e28c05835f159ce6 (diff)
downloadopenembedded-core-contrib-3b1346c607c41a2d592c48594457c32153cb2314.tar.gz
Allow user mode NFS server to run without rpcbind / portmap
and nfsroot mount without the need to talk to an RPC info server as long as the port numbers for mountd and nfsd are known in advance. This patch updates the qemu startup scripts and the user mode NFS server to have the ability to start without the need to use rpcbind or portmap services. Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/unfs-server')
-rw-r--r--meta/recipes-devtools/unfs-server/unfs-server-2.1+2.2beta47/023-no-rpc-register.patch34
-rw-r--r--meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beta47.bb3
2 files changed, 36 insertions, 1 deletions
diff --git a/meta/recipes-devtools/unfs-server/unfs-server-2.1+2.2beta47/023-no-rpc-register.patch b/meta/recipes-devtools/unfs-server/unfs-server-2.1+2.2beta47/023-no-rpc-register.patch
new file mode 100644
index 0000000000..50f23fcc6c
--- /dev/null
+++ b/meta/recipes-devtools/unfs-server/unfs-server-2.1+2.2beta47/023-no-rpc-register.patch
@@ -0,0 +1,34 @@
+Upstream-Status: Inappropriate [other]
+Upstream is not making further releases of this software.
+
+Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
+
+# Allow user mode NFS to work without rpcbind / portmap
+# Patch origin: Wind River
+
+---
+ rpcmisc.c | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+--- a/rpcmisc.c
++++ b/rpcmisc.c
+@@ -91,7 +91,8 @@ not_inetd:
+ if (transp == NULL)
+ Dprintf(L_FATAL, "cannot create udp service.");
+ for (i = 0; (vers = verstbl[i]) != 0; i++) {
+- if (!svc_register(transp, prog, vers, dispatch, IPPROTO_UDP)) {
++ if (!(svc_register(transp, prog, vers, dispatch, IPPROTO_UDP) ||
++ svc_register(transp, prog, vers, dispatch, 0))) {
+ Dprintf(L_FATAL,
+ "unable to register (%s, %d, udp).",
+ name, vers);
+@@ -110,7 +111,8 @@ not_inetd:
+ transp->xp_ops->xp_recv = auth_rendevouser;
+ #endif
+ for (i = 0; (vers = verstbl[i]) != 0; i++) {
+- if (!svc_register(transp, prog, vers, dispatch, IPPROTO_TCP)) {
++ if (!(svc_register(transp, prog, vers, dispatch, IPPROTO_TCP) ||
++ svc_register(transp, prog, vers, dispatch, 0))) {
+ Dprintf(L_FATAL,
+ "unable to register (%s, %d, tcp).",
+ name, vers);
diff --git a/meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beta47.bb b/meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beta47.bb
index 8ed2e33f95..29c7052056 100644
--- a/meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beta47.bb
+++ b/meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beta47.bb
@@ -7,7 +7,7 @@ RDEPENDS_${PN} = "pseudo"
RDEPENDS_${PN}_virtclass-native = "pseudo-native"
RDEPENDS_${PN}_virtclass-nativesdk = "pseudo-nativesdk"
BASEPV = "2.2beta47"
-PR = "r0"
+PR = "r1"
SRC_URI = "ftp://linux.mathematik.tu-darmstadt.de/pub/linux/oldstuff/people/okir/nfs-server-${BASEPV}.tar.gz \
file://001-2.2b47-2.2b51.patch \
@@ -32,6 +32,7 @@ SRC_URI = "ftp://linux.mathematik.tu-darmstadt.de/pub/linux/oldstuff/people/okir
file://020-undefined-chmod-fix.patch \
file://021-nolibwrap.patch \
file://022-add-close-on-exec-descriptors.patch \
+ file://023-no-rpc-register.patch \
"
SRC_URI[md5sum] = "79a29fe9f79b2f3241d4915767b8c511"