summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcltk
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-06-22 16:33:29 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-28 20:54:53 +0100
commite41c0827f54ea81274df98473e27263ef7e02c8d (patch)
treedbb646d6a0e717c272ed911806baff814c5bfd28 /meta/recipes-devtools/tcltk
parent578c8205fd14c48c6d30ef2889d86f1b4aee060a (diff)
downloadopenembedded-core-contrib-e41c0827f54ea81274df98473e27263ef7e02c8d.tar.gz
tcl: cleanups
No need to set DEPENDS_class-native explicitly as self-dependencies are ignored now. Don't rewrite do_configure, autotools_do_configure works. Actually invoke the install-private-headers target (autotools_do_install doesn't take arguments). Remove redundant cd. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/tcltk')
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.6.6.bb13
1 files changed, 2 insertions, 11 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.6.bb b/meta/recipes-devtools/tcltk/tcl_8.6.6.bb
index 40cd18fb09..5cecf65fb6 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.6.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.6.bb
@@ -35,23 +35,15 @@ VER = "${PV}"
inherit autotools ptest binconfig
-DEPENDS_class-native = "zlib-native"
-
EXTRA_OECONF = "--enable-threads --disable-rpath --libdir=${libdir}"
-do_configure() {
- cd ${S}
- gnu-configize
- cd ${B}
- oe_runconf
-}
-
do_compile_prepend() {
echo > ${S}/../compat/fixstrtod.c
}
do_install() {
- autotools_do_install install-private-headers
+ autotools_do_install
+ oe_runmake 'DESTDIR=${D}' install-private-headers
ln -sf ./tclsh${VER} ${D}${bindir}/tclsh
ln -sf tclsh8.6 ${D}${bindir}/tclsh${VER}
sed -i "s;-L${B};-L${STAGING_LIBDIR};g" tclConfig.sh
@@ -59,7 +51,6 @@ do_install() {
install -d ${D}${bindir_crossscripts}
install -m 0755 tclConfig.sh ${D}${bindir_crossscripts}
install -m 0755 tclConfig.sh ${D}${libdir}
- cd ..
for dir in compat generic unix; do
install -d ${D}${includedir}/${BPN}${VER}/$dir
install -m 0644 ${S}/../$dir/*.h ${D}${includedir}/${BPN}${VER}/$dir/