aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcltk/tcl
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-01-17 17:16:51 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-17 10:33:34 +0000
commita263281d9c774a03cce76caa3cc477cc85a9c2a9 (patch)
tree794426f43b42b2ac1f892111d53bec38eb8496c4 /meta/recipes-devtools/tcltk/tcl
parenta9ff0bbac5ae0688525c71f0a358f0750a277269 (diff)
downloadopenembedded-core-contrib-a263281d9c774a03cce76caa3cc477cc85a9c2a9.tar.gz
tcl: fix the TCL_INCLUDE_SPEC
We have moved the header files to ${includedir}/tcl${VERSION}, but we didn't fix the TCL_INCLUDE_SPEC which is still ${includedir}, it should also be ${includedir}/tcl${VERSION} Note: this commit modifiey alter-includedir.patch, so it doesn't look very clear, I only fixed one line in both configure and configure.in: -eval "TCL_INCLUDE_SPEC=\"-I${includedir}\"" +eval "TCL_INCLUDE_SPEC=\"-I${includedir}/tcl${VERSION}\"" The other changes are because I use git to create the patch while the previous one uses svn. [YOCTO #5732] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/tcltk/tcl')
-rw-r--r--meta/recipes-devtools/tcltk/tcl/alter-includedir.patch60
1 files changed, 45 insertions, 15 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl/alter-includedir.patch b/meta/recipes-devtools/tcltk/tcl/alter-includedir.patch
index f543910be9..c8530e1f58 100644
--- a/meta/recipes-devtools/tcltk/tcl/alter-includedir.patch
+++ b/meta/recipes-devtools/tcltk/tcl/alter-includedir.patch
@@ -5,11 +5,20 @@ Upstream-Status: Inappropriate [Configuration Specific]
Signed-off-by: Khem Raj <raj.khem@gmai.com>
-Index: unix/Makefile.in
-===================================================================
---- unix.orig/Makefile.in 2013-11-11 01:00:36.431550403 -0800
-+++ unix/Makefile.in 2013-11-11 01:05:09.587557282 -0800
-@@ -53,7 +53,7 @@
+Fixed the TCL_INCLUDE_SPEC
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ Makefile.in | 2 +-
+ configure | 4 ++--
+ configure.in | 4 ++--
+ 3 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 97b983b..dc2a4df 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -53,7 +53,7 @@ DLL_INSTALL_DIR = @DLL_INSTALL_DIR@
SCRIPT_INSTALL_DIR = $(INSTALL_ROOT)$(TCL_LIBRARY)
# Directory in which to install the include file tcl.h:
@@ -18,11 +27,11 @@ Index: unix/Makefile.in
# Path to the private tcl header dir:
PRIVATE_INCLUDE_DIR = @PRIVATE_INCLUDE_DIR@
-Index: unix/configure.in
-===================================================================
---- unix.orig/configure.in 2013-11-11 01:00:36.467550403 -0800
-+++ unix/configure.in 2013-11-11 01:00:36.503550404 -0800
-@@ -791,7 +791,7 @@
+diff --git a/configure b/configure
+index 3e78b49..24b3f92 100755
+--- a/configure
++++ b/configure
+@@ -19134,7 +19134,7 @@ eval "TCL_LIB_FILE=libtcl${LIB_SUFFIX}"
eval "TCL_LIB_FILE=${TCL_LIB_FILE}"
TCL_LIBRARY='$(libdir)/tcl$(VERSION)'
@@ -31,11 +40,20 @@ Index: unix/configure.in
HTML_DIR='$(DISTDIR)/html'
# Note: in the following variable, it's important to use the absolute
-Index: unix/configure
-===================================================================
---- unix.orig/configure 2013-11-11 01:00:36.467550403 -0800
-+++ unix/configure 2013-11-11 01:00:36.503550404 -0800
-@@ -19134,7 +19134,7 @@
+@@ -19293,7 +19293,7 @@ TCL_BUILD_STUB_LIB_PATH="`pwd`/${TCL_STUB_LIB_FILE}"
+ TCL_STUB_LIB_PATH="${TCL_STUB_LIB_DIR}/${TCL_STUB_LIB_FILE}"
+
+ # Install time header dir can be set via --includedir
+-eval "TCL_INCLUDE_SPEC=\"-I${includedir}\""
++eval "TCL_INCLUDE_SPEC=\"-I${includedir}/tcl${VERSION}\""
+
+ #------------------------------------------------------------------------
+ # tclConfig.sh refers to this by a different name
+diff --git a/configure.in b/configure.in
+index 0e28b14..62d9b41 100755
+--- a/configure.in
++++ b/configure.in
+@@ -791,7 +791,7 @@ eval "TCL_LIB_FILE=libtcl${LIB_SUFFIX}"
eval "TCL_LIB_FILE=${TCL_LIB_FILE}"
TCL_LIBRARY='$(libdir)/tcl$(VERSION)'
@@ -44,3 +62,15 @@ Index: unix/configure
HTML_DIR='$(DISTDIR)/html'
# Note: in the following variable, it's important to use the absolute
+@@ -912,7 +912,7 @@ TCL_BUILD_STUB_LIB_PATH="`pwd`/${TCL_STUB_LIB_FILE}"
+ TCL_STUB_LIB_PATH="${TCL_STUB_LIB_DIR}/${TCL_STUB_LIB_FILE}"
+
+ # Install time header dir can be set via --includedir
+-eval "TCL_INCLUDE_SPEC=\"-I${includedir}\""
++eval "TCL_INCLUDE_SPEC=\"-I${includedir}/tcl${VERSION}\""
+
+ #------------------------------------------------------------------------
+ # tclConfig.sh refers to this by a different name
+--
+1.7.10.4
+