aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/systemd-bootchart
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2016-06-17 11:03:27 +0800
committerChen Qi <Qi.Chen@windriver.com>2016-06-17 11:33:18 +0800
commit9cc3d71a9624333bd6c3c676ee2b855be1903568 (patch)
tree47b27eb12ba7db404a0e046b4f8832cc288bf881 /meta/recipes-devtools/systemd-bootchart
parentfb177ff9d5c3e56fdbce5ab3182b476a1cc0e9d4 (diff)
downloadopenembedded-core-contrib-9cc3d71a9624333bd6c3c676ee2b855be1903568.tar.gz
systemd-bootchart: add recipe
Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/systemd-bootchart')
-rw-r--r--meta/recipes-devtools/systemd-bootchart/systemd-bootchart_230.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_230.bb b/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_230.bb
new file mode 100644
index 0000000000..7c135cbee3
--- /dev/null
+++ b/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_230.bb
@@ -0,0 +1,30 @@
+LICENSE = "LGPLv2.1 & GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c \
+ file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe"
+
+SRC_URI = "git://github.com/systemd/systemd-bootchart.git;protocol=https"
+
+# Modify these as desired
+PV = "230+git${SRCPV}"
+SRCREV = "dcb246b46239259ec99b3c6e6ab7d27e1a5a8a84"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "libxslt-native libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native intltool"
+RDEPENDS_${PN} += "systemd"
+
+inherit pkgconfig autotools systemd
+
+SYSTEMD_SERVICE_${PN} = "systemd-bootchart.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+
+do_configure_prepend() {
+ # intltool.m4 is a soft link to /usr/share/aclocal/m4, delete it and use the one in our sysroot
+ rm ${S}/m4/intltool.m4
+ cp ${STAGING_DIR_TARGET}${datadir}/aclocal/intltool.m4 ${S}/m4/intltool.m4
+}
+
+FILES_${PN} += "${systemd_unitdir}/systemd-bootchart"
+
+EXTRA_OECONF = " --with-rootprefix=${base_prefix} \
+ --with-rootlibdir=${base_libdir}"