aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_233.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-01-21 16:12:15 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2018-01-21 16:12:15 -0800
commit00cd20b9f75de5a0161633a651a27e702cb211d2 (patch)
tree05de6b58103f06197a4e572df0b3576a8a15b306 /meta/recipes-devtools/systemd-bootchart/systemd-bootchart_233.bb
parent3328211afdef8ffb00dd4dff1143959d5412b075 (diff)
downloadopenembedded-core-contrib-00cd20b9f75de5a0161633a651a27e702cb211d2.tar.gz
systemd-bootchart: upgrade to v233; fix build with musltimo/systemd-bootchart
* Drop xlocale.h patch, merged upstream * Rework patches from systemd to fix musl build - comparison_fn_t is glibc specific - musl does not provide printf.h - musl does not provide canonicalize_file_name Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/systemd-bootchart/systemd-bootchart_233.bb')
-rw-r--r--meta/recipes-devtools/systemd-bootchart/systemd-bootchart_233.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_233.bb b/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_233.bb
new file mode 100644
index 0000000000..1ae21b1fbc
--- /dev/null
+++ b/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_233.bb
@@ -0,0 +1,37 @@
+LICENSE = "LGPLv2.1 & GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c \
+ file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe"
+
+SRC_URI = "git://github.com/systemd/systemd-bootchart.git;protocol=https \
+"
+
+SRC_URI_append_libc-musl = " \
+ file://0001-comparison_fn_t-is-glibc-specific-use-raw-signature-.patch \
+ file://0002-musl-does-not-provide-printf-h.patch \
+ file://0003-musl-does-not-provide-canonicalize_file_name.patch \
+ "
+
+
+# Modify these as desired
+PV = "233+git${SRCPV}"
+SRCREV = "fe1c5e41e6bdb78043dad8fa863fc2df66d1dadf"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "systemd libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native intltool"
+
+inherit pkgconfig autotools systemd distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "systemd"
+
+SYSTEMD_SERVICE_${PN} = "systemd-bootchart.service"
+
+do_configure_prepend() {
+ # intltool.m4 is a soft link to /usr/share/aclocal/m4, delete it and use the one in our sysroot
+ rm -f ${S}/m4/intltool.m4
+}
+
+FILES_${PN} += "${systemd_unitdir}/systemd-bootchart"
+
+EXTRA_OECONF = " --with-rootprefix=${base_prefix} \
+ --with-rootlibdir=${base_libdir}"