aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/swig/swig_3.0.12.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2018-08-15 13:20:36 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-15 21:45:10 +0100
commitf0f8ee668de34ad30ca16f5300966a3470018940 (patch)
treecd86170c529ff051167f0620e3e2660b7ee00f61 /meta/recipes-devtools/swig/swig_3.0.12.bb
parentbdf8ae540af12ecc9ad60efd3651b0f71d12d3bd (diff)
downloadopenembedded-core-contrib-f0f8ee668de34ad30ca16f5300966a3470018940.tar.gz
swig: fix gcc8 warnings for cast between incompatible function types
We got an error when building setools in meta-selinux: setools/policyrep/qpol_wrap.c:1819:23: error: cast between incompatible function types from 'PyObject * (*)(PyObject *)' {aka 'struct _object * (*)(struct _object *)'} to 'PyObject * (*)(PyObject *, PyObject *)' {aka 'struct _object * (*)(struct _object *, struct _object *)'} [-Werror=cast-function-type] {(char *)"disown", (PyCFunction)SwigPyObject_disown, METH_NOARGS, (char *)"releases ownership of the pointer"}, This is a swig issue. See: https://github.com/swig/swig/issues/1259 Backport a patch from upstream to fix it. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/swig/swig_3.0.12.bb')
-rw-r--r--meta/recipes-devtools/swig/swig_3.0.12.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/swig/swig_3.0.12.bb b/meta/recipes-devtools/swig/swig_3.0.12.bb
index 429840bde1..fe9d0747f2 100644
--- a/meta/recipes-devtools/swig/swig_3.0.12.bb
+++ b/meta/recipes-devtools/swig/swig_3.0.12.bb
@@ -4,6 +4,7 @@ SRC_URI += "file://0001-Use-proc-self-exe-for-swig-swiglib-on-non-Win32-plat.pat
file://0001-configure-use-pkg-config-for-pcre-detection.patch \
file://0001-Add-Node-7.x-aka-V8-5.2-support.patch \
file://swig-3.0.12-Coverity-fix-issue-reported-for-SWIG_Python_FixMetho.patch \
+ file://Python-Fix-new-GCC8-warnings-in-generated-code.patch \
"
SRC_URI[md5sum] = "82133dfa7bba75ff9ad98a7046be687c"
SRC_URI[sha256sum] = "7cf9f447ae7ed1c51722efc45e7f14418d15d7a1e143ac9f09a668999f4fc94d"