summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
diff options
context:
space:
mode:
authorUlrich Ölmann <u.oelmann@pengutronix.de>2019-07-18 13:50:39 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-19 08:41:40 +0100
commitb4db437f11d47593177b3fdf9d59061c0cafe957 (patch)
tree8e5e3896b3827ca95c3f15ba76422788ff7a4583 /meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
parentf06689bff20b1aff723aaa1c9a011d584fba3780 (diff)
downloadopenembedded-core-contrib-b4db437f11d47593177b3fdf9d59061c0cafe957.tar.gz
squashfs-tools: upgrade to commit f95864afe883
The master branch's current tip commit as of this writing is [1], see the squashfs-tool's repo at [0]. Because of commits [2]-[4] which are included in the master branch three corresponding patches are dropped as they are not needed anymore. The single remaining patch was rebased on top of [1] to apply cleanly. Commits [5] & [6] introduced interesting features, namely zstd support and reproducibility of created SquashFS images. They are reflected in two new PACKAGECONFIG options now, but only the latter ("reproducible") is appended to the default options as OE-core does not contain a recipe to build zstd at the moment (a working zstd recipe can be found e.g. in meta-rauc, see [7]). [0] https://github.com/plougher/squashfs-tools.git [1] f95864afe883 ("unsquashfs-4: Add more sanity checks + fix CVE-2015-4645/6") [2] 46bdc1726e5a ("mksquashfs: Make a load of functions static") [3] b0ca8a5c98ff ("pseudo.c: add explicit <sys/stat.h> include") [4] f95864afe883 ("unsquashfs-4: Add more sanity checks + fix CVE-2015-4645/6") [5] 6113361316d5 ("squashfs-tools: Add zstd support") [6] e0d74d07bb35 ("Add configuration and Mksquashfs build options for reproducible builds") [7] https://layers.openembedded.org/layerindex/recipe/79049/ (From OE-Core rev: 92f34fbe321040db3dc0431dd464747324058e2e) Signed-off-by: Ulrich Ölmann <u.oelmann@pengutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb')
-rw-r--r--meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb b/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
index dc1568a77c..ab2ff01b62 100644
--- a/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
+++ b/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
@@ -6,12 +6,9 @@ LICENSE = "GPL-2"
LIC_FILES_CHKSUM = "file://../COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
PV = "4.3+gitr${SRCPV}"
-SRCREV = "9c1db6d13a51a2e009f0027ef336ce03624eac0d"
+SRCREV = "f95864afe8833fe3ad782d714b41378e860977b1"
SRC_URI = "git://github.com/plougher/squashfs-tools.git;protocol=https \
- file://0001-mksquashfs.c-get-inline-functions-work-with-C99.patch;striplevel=2 \
file://squashfs-tools-4.3-sysmacros.patch;striplevel=2 \
- file://fix-compat.patch \
- file://0001-squashfs-tools-patch-for-CVE-2015-4645-6.patch;striplevel=2 \
"
UPSTREAM_CHECK_COMMITS = "1"
SRC_URI[lzma.md5sum] = "29d5ffd03a5a3e51aef6a74e9eafb759"
@@ -24,13 +21,15 @@ COMPATIBLE_HOST_libc-musl = 'null'
EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS}"
-PACKAGECONFIG ??= "gzip xz lzo lz4 lzma xattr"
+PACKAGECONFIG ??= "gzip xz lzo lz4 lzma xattr reproducible"
PACKAGECONFIG[gzip] = "GZIP_SUPPORT=1,GZIP_SUPPORT=0,zlib"
PACKAGECONFIG[xz] = "XZ_SUPPORT=1,XZ_SUPPORT=0,xz"
PACKAGECONFIG[lzo] = "LZO_SUPPORT=1,LZO_SUPPORT=0,lzo"
PACKAGECONFIG[lz4] = "LZ4_SUPPORT=1,LZ4_SUPPORT=0,lz4"
PACKAGECONFIG[lzma] = "LZMA_XZ_SUPPORT=1,LZMA_XZ_SUPPORT=0,xz"
PACKAGECONFIG[xattr] = "XATTR_SUPPORT=1,XATTR_SUPPORT=0,attr"
+PACKAGECONFIG[zstd] = "ZSTD_SUPPORT=1,ZSTD_SUPPORT=0,zstd"
+PACKAGECONFIG[reproducible] = "REPRODUCIBLE_DEFAULT=1,REPRODUCIBLE_DEFAULT=0,"
do_compile() {
oe_runmake mksquashfs unsquashfs