aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rsync/rsync_3.1.2.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-01-07 01:42:56 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-13 00:03:55 +0000
commit0e3b087f16e2d404803c2b85dd1cb24f4be3e5e6 (patch)
tree532910af0e1a44105e8fac340e65365360be7116 /meta/recipes-devtools/rsync/rsync_3.1.2.bb
parent6638c366b7db67ab59de6aa5d8d8f0e3af2ba707 (diff)
downloadopenembedded-core-contrib-0e3b087f16e2d404803c2b85dd1cb24f4be3e5e6.tar.gz
rsync: 3.1.1 -> 3.1.2
* Remove backport patches: - 0001-Complain-if-an-inc-recursive-path-is-not-right-for-i.patch - rsync.git-eac858085.patch Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/rsync/rsync_3.1.2.bb')
-rw-r--r--meta/recipes-devtools/rsync/rsync_3.1.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rsync/rsync_3.1.2.bb b/meta/recipes-devtools/rsync/rsync_3.1.2.bb
new file mode 100644
index 0000000000..71c2045aed
--- /dev/null
+++ b/meta/recipes-devtools/rsync/rsync_3.1.2.bb
@@ -0,0 +1,28 @@
+require rsync.inc
+
+
+SRC_URI += "file://acinclude.m4 \
+"
+
+SRC_URI[md5sum] = "0f758d7e000c0f7f7d3792610fad70cb"
+SRC_URI[sha256sum] = "ecfa62a7fa3c4c18b9eccd8c16eaddee4bd308a76ea50b5c02a5840f09c0a1c2"
+
+PACKAGECONFIG ??= "acl attr"
+PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
+PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
+
+# rsync 3.0 uses configure.sh instead of configure, and
+# makefile checks the existence of configure.sh
+do_configure_prepend () {
+ rm -f ${S}/configure ${S}/configure.sh
+ cp -f ${WORKDIR}/acinclude.m4 ${S}/
+
+ # By default, if crosscompiling, rsync disables a number of
+ # capabilities, hardlinking symlinks and special files (i.e. devices)
+ export rsync_cv_can_hardlink_special=yes
+ export rsync_cv_can_hardlink_symlink=yes
+}
+
+do_configure_append () {
+ cp -f ${S}/configure ${S}/configure.sh
+}