summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm
diff options
context:
space:
mode:
authorPeter Kjellerstedt <pkj@axis.com>2017-08-15 16:41:52 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-17 00:21:14 +0100
commita38ca789cfbe860cdea37fb86751db2b176f4e25 (patch)
treea4f2e11ef52a9db59f15b8d59697bf93791168a4 /meta/recipes-devtools/rpm
parente25d7a9b9c5f33736ef451282f5e7a00d97e6cc8 (diff)
downloadopenembedded-core-contrib-a38ca789cfbe860cdea37fb86751db2b176f4e25.tar.gz
rpm: Add dependencies on bash, perl and python3-core
Also modify a Python script (pythondistdeps.py) to use Python 3. (From OE-Core rev: b2906dbebfd547a630a4eafdcbaa1ceefa5e257c) Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm')
-rw-r--r--meta/recipes-devtools/rpm/rpm_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_git.bb b/meta/recipes-devtools/rpm/rpm_git.bb
index 59836d0b11..2f814c44e7 100644
--- a/meta/recipes-devtools/rpm/rpm_git.bb
+++ b/meta/recipes-devtools/rpm/rpm_git.bb
@@ -107,6 +107,9 @@ do_install_append_class-target() {
do_install_append () {
sed -i -e 's:${HOSTTOOLS_DIR}/::g' ${D}/${libdir}/rpm/macros
+
+ sed -i -e 's|/usr/bin/python|${USRBINPATH}/env ${PYTHON_PN}|' \
+ ${D}${libdir}/rpm/pythondistdeps.py
}
FILES_${PN} += "${libdir}/rpm-plugins/*.so \
@@ -121,3 +124,5 @@ FILES_python3-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/*"
# rpm 5.x was packaging the rpm build tools separately
RPROVIDES_${PN} += "rpm-build"
+
+RDEPENDS_${PN} = "bash perl python3-core"