summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-04 11:56:25 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-12 08:45:36 +0100
commit099224f81bafb8a2ec0ec7ee4ad77756d2372c24 (patch)
treedaf38e938bcc790c9dfc6759bfd0eae57d113425 /meta/recipes-devtools/rpm
parent641ba7069a1b5d3ea1e9da16ada1181575ca70cc (diff)
downloadopenembedded-core-contrib-099224f81bafb8a2ec0ec7ee4ad77756d2372c24.tar.gz
rpm: Ensure macros file doesn't reference HOSTTOOLS
Currently the file encodes full paths to various host tools in the HOSTTOOLS directory which is bad in native and target cases. We can simply use the versions from PATH quite safely in OE. (From OE-Core rev: be901200d94beaa35e1d05eb502b117b3b523609) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm')
-rw-r--r--meta/recipes-devtools/rpm/rpm_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_git.bb b/meta/recipes-devtools/rpm/rpm_git.bb
index f31932ef55..2310ee6b09 100644
--- a/meta/recipes-devtools/rpm/rpm_git.bb
+++ b/meta/recipes-devtools/rpm/rpm_git.bb
@@ -128,6 +128,10 @@ do_install_append_class-target() {
rm -rf ${D}/var
}
+do_install_append () {
+ sed -i -e 's:${HOSTTOOLS_DIR}/::g' ${D}/${libdir}/rpm/macros
+}
+
FILES_${PN} += "${libdir}/rpm-plugins/*.so \
"