aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2016-03-04 13:02:50 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-09 17:00:28 +0000
commit5699c670795e77cb709324132a7299e877963749 (patch)
treeb648503daf8eb0b11e4133b9f952f267da29fb79 /meta/recipes-devtools/rpm
parent8ea55ba895286aac9c33918434d3b008101ecb46 (diff)
downloadopenembedded-core-contrib-5699c670795e77cb709324132a7299e877963749.tar.gz
rpmresolve: It is not necessary to manually specify -lpopt
Popt may be internal or external to rpm. Either way the rpm libraries will link properly with or without -lpopt. (From OE-Core rev: b79a628d59382fdba812c67133c93e9f4ea365c2) Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm')
-rw-r--r--meta/recipes-devtools/rpm/rpmresolve_1.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/rpm/rpmresolve_1.0.bb b/meta/recipes-devtools/rpm/rpmresolve_1.0.bb
index 04a55fd480..0c13a67107 100644
--- a/meta/recipes-devtools/rpm/rpmresolve_1.0.bb
+++ b/meta/recipes-devtools/rpm/rpmresolve_1.0.bb
@@ -11,7 +11,7 @@ SRC_URI = "file://rpmresolve.c"
S = "${WORKDIR}"
do_compile() {
- ${CC} ${CFLAGS} -ggdb -I${STAGING_INCDIR}/rpm ${LDFLAGS} rpmresolve.c -o rpmresolve -lrpmbuild -lrpm -lrpmio -lrpmdb -lpopt
+ ${CC} ${CFLAGS} -ggdb -I${STAGING_INCDIR}/rpm ${LDFLAGS} rpmresolve.c -o rpmresolve -lrpmbuild -lrpm -lrpmio -lrpmdb
}
do_install() {