aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-01-25 11:28:57 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-25 12:35:24 +0000
commite43a72af9055b76eb2ad7e2e42e6a5f3c8854efa (patch)
treebea87968b71892c68793395a0bb69151e6cc0879 /meta/recipes-devtools/rpm
parent2e2a91025ca9c113365c810ce08b48201fe792b8 (diff)
downloadopenembedded-core-contrib-e43a72af9055b76eb2ad7e2e42e6a5f3c8854efa.tar.gz
rpm: properly disable perl file dependency checking for rpmdeps
We don't want the perl module dependencies being added to each package by rpmdeps because it causes too many problems when the modules aren't available at install time (since they get added in do_package which is too late for the build system to ensure they are available), and it appears that the perl dependency gathering isn't working reliably in any case judging by how they are detected on some build hosts and not others. This was being disabled previously but it seems like the macros moved to a different file at some point and nobody noticed; thus make sure we disable the macros in all RPM macro files. Should fix [YOCTO #3699]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.9.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.9.bb b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
index c916a42d5e..6977131a28 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.9.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
@@ -373,8 +373,8 @@ do_configure() {
do_install_append() {
sed -i -e 's,%__check_files,#%%__check_files,' ${D}/${libdir}/rpm/macros
sed -i -e 's,%__scriptlet_requires,#%%__scriptlet_requires,' ${D}/${libdir}/rpm/macros
- sed -i -e 's,%__perl_provides,#%%__perl_provides,' ${D}/${libdir}/rpm/macros
- sed -i -e 's,%__perl_requires,#%%__perl_requires,' ${D}/${libdir}/rpm/macros
+ sed -i -e 's,%__perl_provides,#%%__perl_provides,' ${D}/${libdir}/rpm/macros ${D}/${libdir}/rpm/macros.d/*
+ sed -i -e 's,%__perl_requires,#%%__perl_requires,' ${D}/${libdir}/rpm/macros ${D}/${libdir}/rpm/macros.d/*
sed -i -e 's,%_repackage_all_erasures[^_].*,%_repackage_all_erasures 0,' ${D}/${libdir}/rpm/macros
sed -i -e 's,^#%_openall_before_chroot.*,%_openall_before_chroot\t1,' ${D}/${libdir}/rpm/macros