aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2012-10-27 16:48:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-02 16:15:30 +0000
commitbb67ddeb2eed3e25c626a279ef53a7e8c7bfe6f2 (patch)
treea5cd401b043e80311db7497dec8c791b873aab2e /meta/recipes-devtools/rpm
parent528b4ab831c7b0bc1412318d29e2b7f9cf711d57 (diff)
downloadopenembedded-core-contrib-bb67ddeb2eed3e25c626a279ef53a7e8c7bfe6f2.tar.gz
recipes-devtools: replace virtclass-native(sdk) with class-native(sdk)
The overrides virtclass-native and virtclass-nativesdk are deprecated, which should be replaced by class-native and class-nativesdk. [YOCTO #3297] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/rpm')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.9.bb6
-rw-r--r--meta/recipes-devtools/rpm/rpmresolve_1.0.bb2
2 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.9.bb b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
index e838f40faa..3268160d86 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.9.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
@@ -91,13 +91,13 @@ acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
# Specify the default rpm macros in terms of adjustable variables
rpm_macros = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:%{_etcrpm}/macros.*:%{_etcrpm}/macros:%{_etcrpm}/%{_target}/macros:~/.oerpmmacros"
-rpm_macros_virtclass-native = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros"
+rpm_macros_class-native = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros"
# sqlite lua tcl augeas nss gcrypt neon xz xar keyutils perl selinux
# Note: perl and sqlite w/o db specified does not currently work.
# tcl, augeas, nss, gcrypt, xar and keyutils support is untested.
-PACKAGECONFIG_virtclass-native ??= "db bzip2 zlib beecrypt openssl libelf python"
+PACKAGECONFIG_class-native ??= "db bzip2 zlib beecrypt openssl libelf python"
PACKAGECONFIG ??= "db bzip2 zlib beecrypt openssl libelf python"
PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2,"
@@ -431,7 +431,7 @@ do_install_append() {
rm -f ${D}/usr/lib/rpm/bin/api-sanity-checker.pl
}
-do_install_append_virtclass-native() {
+do_install_append_class-native() {
create_wrapper ${D}/${bindir}/rpm \
RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
diff --git a/meta/recipes-devtools/rpm/rpmresolve_1.0.bb b/meta/recipes-devtools/rpm/rpmresolve_1.0.bb
index ea542e1cc3..48c52c0403 100644
--- a/meta/recipes-devtools/rpm/rpmresolve_1.0.bb
+++ b/meta/recipes-devtools/rpm/rpmresolve_1.0.bb
@@ -19,7 +19,7 @@ do_install() {
install -m 0755 rpmresolve ${D}${bindir}
}
-do_install_append_virtclass-native() {
+do_install_append_class-native() {
create_wrapper ${D}/${bindir}/rpmresolve \
RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \