aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-05-31 12:05:39 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-31 14:02:40 +0100
commita67b4cfc41819ed77ed2bc4246228e9d006a4317 (patch)
tree64a6fed9c30d5ed9386395c52949403699d64686 /meta/recipes-devtools/rpm
parentbb6e59e58033edac509d449b4be916ad6a0a5ad1 (diff)
downloadopenembedded-core-contrib-a67b4cfc41819ed77ed2bc4246228e9d006a4317.tar.gz
rpm: remove .real hacks in argument parsing
The argument parser in RPM was patched to look for <binary>.real, but since the wrapper now fakes the right argv[0] rpm wasn't able to parse any options. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.9.bb4
1 files changed, 0 insertions, 4 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.9.bb b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
index 2dbdca6e6f..25ec23e811 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.9.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
@@ -478,10 +478,6 @@ do_install_append_class-native() {
RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
done
-
- # Adjust popt macros to match...
- cat ${D}/${libdir}/rpm/rpmpopt | sed -e "s,^\(rpm[^ ]*\)\([ ]\),\1.real\2," > ${D}/${libdir}/rpm/rpmpopt.new
- mv ${D}/${libdir}/rpm/rpmpopt.new ${D}/${libdir}/rpm/rpmpopt
}
BBCLASSEXTEND = "native"