aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-18 01:36:35 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-18 13:17:39 +0000
commit6c2d3ced1af4e7ebc63e9a9ac9353d565d1568bf (patch)
tree3cb7afaa739c16e890965ad0cc2f3552bc0feec0 /meta/recipes-devtools/rpm
parentf265de26fcde98cdc7a8e4bfec777888a216ff8c (diff)
downloadopenembedded-core-contrib-6c2d3ced1af4e7ebc63e9a9ac9353d565d1568bf.tar.gz
rpm: Fix case where ${B} != ${S}
Fix out of tree builds by removing assumptions about cwd and using full paths to files in ${S}. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.9.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.9.bb b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
index cdfb5ff4bc..6286771efa 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.9.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
@@ -358,13 +358,13 @@ FILES_${PN}-staticdev = " \
do_configure() {
# Disable tests!
- echo "all:" > tests/Makefile.am
+ echo "all:" > ${S}/tests/Makefile.am
- ./autogen.sh
+ ${S}/autogen.sh
# NASTY hack to make sure configure files the right pkg-config file...
sed -e 's/pkg-config --exists uuid/pkg-config --exists ossp-uuid/g' \
- -e 's/pkg-config uuid/pkg-config ossp-uuid/g' -i configure
+ -e 's/pkg-config uuid/pkg-config ossp-uuid/g' -i ${S}/configure
export varprefix=${localstatedir}
oe_runconf