aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-07-06 15:06:42 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-09 11:34:50 +0100
commit6b3c9802b659ca1d3b7638ff80e6492cc0e16d6f (patch)
tree80338bd380d3d5e2617f0c76ac7c03626e9d453c /meta/recipes-devtools/rpm
parent92ede8a994b9a24387d3d7dc79e80705f6be4524 (diff)
downloadopenembedded-core-contrib-6b3c9802b659ca1d3b7638ff80e6492cc0e16d6f.tar.gz
rpm: Fix PACKAGECONFIG dependencies
neon requires expat to be built first lua similarly requires expat if enabled selinux package name should be "libselinux" (from meta-selinux). Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.9.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.9.bb b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
index 8e892a8389..6ef1aae025 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.9.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
@@ -43,7 +43,7 @@ LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
DEPENDS = "libpcre attr acl popt ossp-uuid file"
-PR = "r44"
+PR = "r45"
# rpm2cpio is a shell script, which is part of the rpm src.rpm. It is needed
# in order to extract the distribution SRPM into a format we can extract...
@@ -129,13 +129,13 @@ PACKAGECONFIG[libelf] = "--with-libelf,--without-libelf,elfutils,"
WITH_SELINUX = "--with-selinux --with-sepol --with-semanage"
WITHOUT_SELINUX = "--without-selinux --without-sepol --without-semanage"
-PACKAGECONFIG[selinux] = "${WITH_SELINUX},${WITHOUT_SELINUX},selinux,"
+PACKAGECONFIG[selinux] = "${WITH_SELINUX},${WITHOUT_SELINUX},libselinux,"
WITH_NEON = "--with-neon --with-libproxy --with-expat --without-gssapi"
WITHOUT_NEON = "--without-neon --without-libproxy --without-expat --without-gssapi"
-PACKAGECONFIG[neon] = "${WITH_NEON},${WITHOUT_NEON},neon,"
+PACKAGECONFIG[neon] = "${WITH_NEON},${WITHOUT_NEON},neon expat,"
-PACKAGECONFIG[lua] = "--with-lua,--without-lua,"
+PACKAGECONFIG[lua] = "--with-lua,--without-lua,expat,"
PACKAGECONFIG[tcl] = "--with-tcl,--without-tcl,tcl,"
PACAKGECONFIG[augeas] = "--with-augeas,--without-augeas,augeas,"