aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2013-07-19 17:39:25 +0800
committerSaul Wold <sgw@linux.intel.com>2013-07-27 23:28:27 -0700
commit308185c215b8dd969d1230e52444ce3c11fc2c57 (patch)
treeab62ac3304ccbf7e82bd7b5e669d1a05b3c1edba /meta/recipes-devtools/rpm
parent239d46d9060ee4f30da4f7633377639283f16453 (diff)
downloadopenembedded-core-contrib-308185c215b8dd969d1230e52444ce3c11fc2c57.tar.gz
rpm: remove the obsolete rpm-postinsts.bb
Now that the postinsts of rpm, deb and ipk are all handled in the one central place, run-postinsts.bb, the rpm-postinsts.bb recipe is actually obsolete now. Remove this recipe to avoid confusion. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/rpm')
-rw-r--r--meta/recipes-devtools/rpm/rpm-postinsts.bb54
1 files changed, 0 insertions, 54 deletions
diff --git a/meta/recipes-devtools/rpm/rpm-postinsts.bb b/meta/recipes-devtools/rpm/rpm-postinsts.bb
deleted file mode 100644
index ba58cd49b1..0000000000
--- a/meta/recipes-devtools/rpm/rpm-postinsts.bb
+++ /dev/null
@@ -1,54 +0,0 @@
-DESCRIPTION = "RPM postinstall script"
-SECTION = "core"
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/LGPL-2.1;md5=1a6d268fd218675ffea8be556788b780"
-
-inherit allarch
-#
-# Allow distributions to alter when [postponed] package install scripts are run
-#
-POSTINSTALL_INITPOSITION ?= "98"
-
-do_fetch() {
- :
-}
-
-do_configure() {
- :
-}
-
-do_compile() {
- :
-}
-
-do_install() {
- :
-}
-
-pkg_postinst_${PN} () {
-if [ "x$D" != "x" ] && [ -f $D/var/lib/rpm/Packages ]; then
- install -d $D/${sysconfdir}/rcS.d
- cat > $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}run-postinsts << "EOF"
-#!/bin/sh
-[ -e ${sysconfdir}/default/postinst ] && . ${sysconfdir}/default/postinst
-[ -d ${sysconfdir}/rpm-postinsts ] && for i in `ls ${sysconfdir}/rpm-postinsts/`; do
- i=${sysconfdir}/rpm-postinsts/$i
- echo "Running postinst $i..."
- if [ -x $i ]; then
- if [ "$POSTINST_LOGGING" = "1" ]; then
- $i >>$LOGFILE 2>&1
- else
- $i
- fi
- rm $i
- else
- echo "ERROR: postinst $i failed."
- fi
-done
-rm -f ${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}run-postinsts 2>/dev/null
-EOF
- chmod 0755 $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}run-postinsts
-fi
-}
-
-ALLOW_EMPTY_${PN} = "1"