aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2014-07-02 19:57:45 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-08 11:19:48 +0100
commit17419e4577eb4b5786d4c0120f070e1660fa28ec (patch)
treee84633b0a31714caa219a527510e0a41aca723a7 /meta/recipes-devtools/rpm
parent0c7b4a5e23836889196f85f472f081d51529e94e (diff)
downloadopenembedded-core-contrib-17419e4577eb4b5786d4c0120f070e1660fa28ec.tar.gz
rpm: Replace patch with backport from SCM version of RPM5
Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm')
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-verify-files.patch22
-rw-r--r--meta/recipes-devtools/rpm/rpm/verify-fix-broken-logic-for-ghost-avoidance-Mark-Hat.patch38
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.14.bb2
3 files changed, 39 insertions, 23 deletions
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-verify-files.patch b/meta/recipes-devtools/rpm/rpm/rpm-verify-files.patch
deleted file mode 100644
index 3492da5b55..0000000000
--- a/meta/recipes-devtools/rpm/rpm/rpm-verify-files.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-lib/verify.c: Fix rpm -V file processing
-
-rpm -V should verify the md5sum and other values on individual files.
-A logic error in the query for GHOST files prevented this from working.
-
-[ Upstream-Status: Submitted ]
-
-Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-
-Index: rpm-5.4.14/lib/verify.c
-===================================================================
---- rpm-5.4.14.orig/lib/verify.c
-+++ rpm-5.4.14/lib/verify.c
-@@ -589,7 +589,7 @@ uint32_t fc = rpmfiFC(fi);
-
- /* If not verifying %ghost, skip ghost files. */
- /* XXX the broken!!! logic disables %ghost queries always. */
-- if (!(FF_ISSET(qva->qva_fflags, GHOST) && FF_ISSET(fflags, GHOST)))
-+ if (!(FF_ISSET(qva->qva_fflags, GHOST)) && FF_ISSET(fflags, GHOST))
- continue;
-
- /* Gather per-file data into a carrier. */
diff --git a/meta/recipes-devtools/rpm/rpm/verify-fix-broken-logic-for-ghost-avoidance-Mark-Hat.patch b/meta/recipes-devtools/rpm/rpm/verify-fix-broken-logic-for-ghost-avoidance-Mark-Hat.patch
new file mode 100644
index 0000000000..5a70f14f29
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm/verify-fix-broken-logic-for-ghost-avoidance-Mark-Hat.patch
@@ -0,0 +1,38 @@
+From 9e7b72ee0c994609975981e135fc18d0387aefb6 Mon Sep 17 00:00:00 2001
+From: jbj <jbj>
+Date: Wed, 14 May 2014 21:19:41 +0000
+Subject: [PATCH] - verify: fix: broken logic for %ghost avoidance (Mark
+ Hatle).
+
+Upstream-status: backport
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+---
+ CHANGES | 1 +
+ lib/verify.c | 3 +--
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+Index: rpm-5.4.14/CHANGES
+===================================================================
+--- rpm-5.4.14.orig/CHANGES
++++ rpm-5.4.14/CHANGES
+@@ -1,3 +1,5 @@
++ - jbj: verify: fix: broken logic for %ghost avoidance (Mark Hatle).
++
+ 5.4.13 -> 5.4.14:
+ - mooney: use __sun instead of __sun__ in #define (lp#1243472).
+ - mooney: rpmconstant: ensure linkage w Oracle Studio 12.3 (lp#1243469).
+Index: rpm-5.4.14/lib/verify.c
+===================================================================
+--- rpm-5.4.14.orig/lib/verify.c
++++ rpm-5.4.14/lib/verify.c
+@@ -588,8 +588,7 @@ uint32_t fc = rpmfiFC(fi);
+ continue;
+
+ /* If not verifying %ghost, skip ghost files. */
+- /* XXX the broken!!! logic disables %ghost queries always. */
+- if (!(FF_ISSET(qva->qva_fflags, GHOST) && FF_ISSET(fflags, GHOST)))
++ if (!FF_ISSET(qva->qva_fflags, GHOST) && FF_ISSET(fflags, GHOST))
+ continue;
+
+ /* Gather per-file data into a carrier. */
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.14.bb b/meta/recipes-devtools/rpm/rpm_5.4.14.bb
index e1c6abb3d8..cc836befe0 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.14.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.14.bb
@@ -86,7 +86,7 @@ SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.14-0.20131024.src.rpm;e
file://rpm-platform-file-fix.patch \
file://rpm-lsb-compatibility.patch \
file://rpm-tag-generate-endian-conversion-fix.patch \
- file://rpm-verify-files.patch \
+ file://verify-fix-broken-logic-for-ghost-avoidance-Mark-Hat.patch \
file://rpm-hardlink-segfault-fix.patch \
file://rpm-payload-use-hashed-inode.patch \
file://rpm-fix-logio-cp.patch \