aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpmresolve_1.0.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-13 18:54:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-13 20:08:42 +0100
commit44c2fb7ea0228dd749129d334c76a1bd2983e585 (patch)
treea5ce0cba9b7453d50ae79fd972c8f5ffa8dd60fa /meta/recipes-devtools/rpm/rpmresolve_1.0.bb
parent3d27ee3da296b57b6bc702431437e635c53697f7 (diff)
downloadopenembedded-core-contrib-44c2fb7ea0228dd749129d334c76a1bd2983e585.tar.gz
rpmresolve: add wrapper script to fix paths
Fixes sstate relocation due to the path to /etc/rpm being baked into the libraries - this manifested in the form of the following assertion at runtime: rpmresolve: dbconfig.c:493: db3New: Assertion `dbOpts != ((void *)0) && *dbOpts != '\0'' failed. Fixes [YOCTO #2936]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpmresolve_1.0.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpmresolve_1.0.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-devtools/rpm/rpmresolve_1.0.bb b/meta/recipes-devtools/rpm/rpmresolve_1.0.bb
index f8750e02ba..3ce4369d0c 100644
--- a/meta/recipes-devtools/rpm/rpmresolve_1.0.bb
+++ b/meta/recipes-devtools/rpm/rpmresolve_1.0.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "OpenEmbedded RPM resolver - performs RPM database lookups in batc
DEPENDS = "rpm"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PR = "r0"
+PR = "r1"
SRC_URI = "file://rpmresolve.c"
@@ -19,4 +19,11 @@ do_install() {
install -m 0755 rpmresolve ${D}${bindir}
}
+do_install_append_virtclass-native() {
+ create_wrapper ${D}/${bindir}/rpmresolve \
+ RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
+ RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
+ RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
+}
+
BBCLASSEXTEND = "native"