aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpmresolve_1.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-12-30 17:59:36 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-13 09:43:21 +0000
commit127112fa05c7102dacda4173adf380c557bacecb (patch)
tree7901a867d1611acce0071bd2432224b0ba5038c8 /meta/recipes-devtools/rpm/rpmresolve_1.0.bb
parentc1d008066f36701b8a8f36ddaeaa626ca6427aed (diff)
downloadopenembedded-core-contrib-127112fa05c7102dacda4173adf380c557bacecb.tar.gz
rpmresolve: remove the recipe
The source code is incompatible with rpm4 API - let's use rpm binary itself for now. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpmresolve_1.0.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpmresolve_1.0.bb29
1 files changed, 0 insertions, 29 deletions
diff --git a/meta/recipes-devtools/rpm/rpmresolve_1.0.bb b/meta/recipes-devtools/rpm/rpmresolve_1.0.bb
deleted file mode 100644
index 0c13a67107..0000000000
--- a/meta/recipes-devtools/rpm/rpmresolve_1.0.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-SUMMARY = "OpenEmbedded RPM resolver utility"
-DESCRIPTION = "OpenEmbedded RPM resolver - performs RPM database lookups in batches to avoid \
- repeated invocations of rpm on the command line."
-DEPENDS = "rpm"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PR = "r2"
-
-SRC_URI = "file://rpmresolve.c"
-
-S = "${WORKDIR}"
-
-do_compile() {
- ${CC} ${CFLAGS} -ggdb -I${STAGING_INCDIR}/rpm ${LDFLAGS} rpmresolve.c -o rpmresolve -lrpmbuild -lrpm -lrpmio -lrpmdb
-}
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 rpmresolve ${D}${bindir}
-}
-
-do_install_append_class-native() {
- create_wrapper ${D}/${bindir}/rpmresolve \
- RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
- RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
- RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
-}
-
-BBCLASSEXTEND = "native nativesdk"