aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-06-11 13:18:54 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-12 11:05:42 +0100
commit8a2b55c5b7c544ec15113bc21e5c62276449c9c3 (patch)
tree23dae974e64c26ff4389e9f42175bd33ad29d6a4 /meta/recipes-devtools/rpm/rpm
parentbf94103d4c532ffdfdcdcc6d27c9f65f7824f8f8 (diff)
downloadopenembedded-core-contrib-8a2b55c5b7c544ec15113bc21e5c62276449c9c3.tar.gz
ossp-uuid: Add oss-uuid package and RPM 5.4.9 integration
RPM 5.4.9 now strongly encourages you to have the ossp-uuid library available. Add this recipe, and change RPM to use the uuid functionality. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm')
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-ossp-uuid.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-ossp-uuid.patch b/meta/recipes-devtools/rpm/rpm/rpm-ossp-uuid.patch
new file mode 100644
index 0000000000..1f4ba980b1
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm/rpm-ossp-uuid.patch
@@ -0,0 +1,20 @@
+Fix integration of ossp-uuid
+
+We need to avoid including the util-linux uuid library, instead
+we need ossp-uuid. There is a related hack in do_configure to
+make sure that we use the right .pc file as well.
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+diff -ur rpm-5.4.9.orig/configure.ac rpm-5.4.9/configure.ac
+--- rpm-5.4.9.orig/configure.ac 2012-05-17 16:37:20.594790192 -0500
++++ rpm-5.4.9/configure.ac 2012-05-17 16:39:23.126933596 -0500
+@@ -1909,7 +1909,7 @@
+ esac
+ RPM_CHECK_LIB(
+ [OSSP uuid], [uuid],
+- [ossp-uuid uuid], [uuid_import], [uuid.h],
++ [ossp-uuid], [uuid_import], [uuid.h],
+ [no,external:none], [],
+ [ dnl # enable OSSP uuid native API support for embedded Lua
+ if test ".$WITH_LUA" = .yes; then