aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm/rpm-lua.patch
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-06-11 13:18:53 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-12 11:02:08 +0100
commitbf94103d4c532ffdfdcdcc6d27c9f65f7824f8f8 (patch)
tree06d74c69dbfa89dde701ab41fa211a2a1530d152 /meta/recipes-devtools/rpm/rpm/rpm-lua.patch
parentc5898ef3fc3820ff9c44bc5b1b16e5def64aa877 (diff)
downloadopenembedded-core-contrib-bf94103d4c532ffdfdcdcc6d27c9f65f7824f8f8.tar.gz
rpm: Upgrade RPM to 5.4.9
Beside upreving RPM, add necessary integration patches to libzypp. Also change the configuration of RPM to support PACKAGECONFIG flags. RPM is highly configurable, the default configuration is good for minimal OE-Core use. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm/rpm-lua.patch')
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-lua.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-lua.patch b/meta/recipes-devtools/rpm/rpm/rpm-lua.patch
new file mode 100644
index 0000000000..980e1b1476
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm/rpm-lua.patch
@@ -0,0 +1,29 @@
+Add support for cross compiling lua
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+diff -ur rpm-5.4.9.orig/configure.ac rpm-5.4.9/configure.ac
+--- rpm-5.4.9.orig/configure.ac 2012-05-16 12:16:36.589813548 -0500
++++ rpm-5.4.9/configure.ac 2012-05-16 12:26:01.070813518 -0500
+@@ -120,6 +120,9 @@
+
+ AC_PATH_PROG(AS, as, as)
+
++CC_FOR_BUILD=${CC_FOR_BUILD-\$(CC)}
++AC_SUBST(CC_FOR_BUILD)
++
+ dnl # GCC specifics
+ AC_PROG_GCC_TRADITIONAL
+ AC_ARG_ENABLE(build-pic,
+diff -ur rpm-5.4.9.orig/lua/Makefile.am rpm-5.4.9/lua/Makefile.am
+--- rpm-5.4.9.orig/lua/Makefile.am 2012-04-07 19:15:25.000000000 -0500
++++ rpm-5.4.9/lua/Makefile.am 2012-05-16 12:26:19.556856688 -0500
+@@ -40,7 +40,7 @@
+
+ # --- bin2c doesn't need anything but a compiler
+ bin2c$(EXEEXT): bin2c.c
+- $(CC) -o $@ $<
++ $(CC_FOR_BUILD) -o $@ $<
+
+ liblua_la_SOURCES =
+ liblua_la_CFLAGS = @WITH_LUA_SUBDIR_DEF@