aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm/rpm-hardlink-segfault-fix.patch
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2014-07-02 19:57:44 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-08 11:19:48 +0100
commit0c7b4a5e23836889196f85f472f081d51529e94e (patch)
treef300a95188e10f51ddd30f53ee2eff73e92d41ff /meta/recipes-devtools/rpm/rpm/rpm-hardlink-segfault-fix.patch
parent04bb223110da2f92725c341bc3ec0cf26325f675 (diff)
downloadopenembedded-core-contrib-0c7b4a5e23836889196f85f472f081d51529e94e.tar.gz
rpm: Upgrade to 5.4.14
Update various patches. A few corrections to the patch descriptions, otherwise simple quilt refresh or conflict resolution. Remove rpm-solvedb.patch and rpm-respect-arch.patch. These are both related to the old solvedb package dependency solver. This is no longer used since we moved to smartpm. rpm-stub-out-git_strerror was a backport and is no longer needed. RPM 5.4.12 and newer normally requires Berkley DB 6.0 or newer. A small patch to configure allows RPM to dynamically select DB 5.3 or DB 6.0 based on what is available at configure time. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm/rpm-hardlink-segfault-fix.patch')
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-hardlink-segfault-fix.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-hardlink-segfault-fix.patch b/meta/recipes-devtools/rpm/rpm/rpm-hardlink-segfault-fix.patch
index 8c2a04a3d5..5deb2323ef 100644
--- a/meta/recipes-devtools/rpm/rpm/rpm-hardlink-segfault-fix.patch
+++ b/meta/recipes-devtools/rpm/rpm/rpm-hardlink-segfault-fix.patch
@@ -10,11 +10,11 @@ RP 2014/6/10
Upstream-Status: Pending
-Index: rpm-5.4.9/lib/fsm.c
+Index: rpm-5.4.14/lib/fsm.c
===================================================================
---- rpm-5.4.9.orig/lib/fsm.c 2014-06-10 10:54:08.601049402 +0000
-+++ rpm-5.4.9/lib/fsm.c 2014-06-10 10:55:45.633046077 +0000
-@@ -495,6 +495,11 @@
+--- rpm-5.4.14.orig/lib/fsm.c
++++ rpm-5.4.14/lib/fsm.c
+@@ -495,6 +495,11 @@ static int saveHardLink(/*@special@*/ /*
}
if (fsm->goal == IOSM_PKGBUILD) --fsm->li->linksLeft;
@@ -26,7 +26,7 @@ Index: rpm-5.4.9/lib/fsm.c
fsm->li->filex[fsm->li->linksLeft] = fsm->ix;
/*@-observertrans -dependenttrans@*/
fsm->li->nsuffix[fsm->li->linksLeft] = fsm->nsuffix;
-@@ -1876,8 +1881,13 @@
+@@ -1878,8 +1883,13 @@ if (!(fsmGetFi(fsm)->mapflags & IOSM_PAY
fsm->postpone = iosmFileActionSkipped(fsm->action);
if (fsm->goal == IOSM_PKGINSTALL || fsm->goal == IOSM_PKGBUILD) {
/*@-evalorder@*/ /* FIX: saveHardLink can modify fsm */