aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm/rpm-fix-logio-cp.patch
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2014-07-02 19:57:44 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-08 11:19:48 +0100
commit0c7b4a5e23836889196f85f472f081d51529e94e (patch)
treef300a95188e10f51ddd30f53ee2eff73e92d41ff /meta/recipes-devtools/rpm/rpm/rpm-fix-logio-cp.patch
parent04bb223110da2f92725c341bc3ec0cf26325f675 (diff)
downloadopenembedded-core-contrib-0c7b4a5e23836889196f85f472f081d51529e94e.tar.gz
rpm: Upgrade to 5.4.14
Update various patches. A few corrections to the patch descriptions, otherwise simple quilt refresh or conflict resolution. Remove rpm-solvedb.patch and rpm-respect-arch.patch. These are both related to the old solvedb package dependency solver. This is no longer used since we moved to smartpm. rpm-stub-out-git_strerror was a backport and is no longer needed. RPM 5.4.12 and newer normally requires Berkley DB 6.0 or newer. A small patch to configure allows RPM to dynamically select DB 5.3 or DB 6.0 based on what is available at configure time. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm/rpm-fix-logio-cp.patch')
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-fix-logio-cp.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-fix-logio-cp.patch b/meta/recipes-devtools/rpm/rpm/rpm-fix-logio-cp.patch
new file mode 100644
index 0000000000..fa1ff43d6c
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm/rpm-fix-logio-cp.patch
@@ -0,0 +1,30 @@
+Occasionally the cp -p fails with a non-zero return code. This will cause
+the system abort the build.
+
+Upstream-status: Pending
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+Index: rpm/rpmdb/Makefile.am
+===================================================================
+--- rpm.orig/rpmdb/Makefile.am
++++ rpm/rpmdb/Makefile.am
+@@ -234,11 +234,14 @@ lcov-report:
+ #lcov-upload: lcov
+ # rsync -rvz -e ssh --delete lcov/* ???
+
++$(builddir)/logio_recover_template: $(srcdir)/logio_recover_template
++ @if test ".$(builddir)" != ".$(srcdir)"; then \
++ cp -fp $(srcdir)/logio_recover_template \
++ $(builddir)/logio_recover_template ; \
++ fi
++
+ logio_BUILT = logio_auto.c logio_autop.c logio_auto.h logio_template
+-$(logio_BUILT): logio.awk logio.src logio_recover_template
+- @test -e $(builddir)/logio_recover_template || \
+- cp -p $(srcdir)/logio_recover_template \
+- $(builddir)/logio_recover_template
++$(logio_BUILT): logio.awk logio.src $(builddir)/logio_recover_template
+ @rm -f $(logio_BUILT)
+ @$(AWK) -f $(srcdir)/logio.awk \
+ -v header_file=logio_auto.h \