aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/remake/remake_git.bb
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2012-07-23 13:50:53 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-26 14:39:48 +0100
commit823fab378bd46da6a296a67f981dffb31b1c8061 (patch)
treec11b0af8c668e31ccb91d67a7c2f4efa6e1e1a6d /meta/recipes-devtools/remake/remake_git.bb
parentc8de655e8f5b2ac8b72428252645022458460912 (diff)
downloadopenembedded-core-contrib-823fab378bd46da6a296a67f981dffb31b1c8061.tar.gz
remake: Add remake-native and remake
remake is a patched version of GNU Make that adds improved error reporting, the ability to trace execution in a comprehensible way, and a debugger. [YOCTO #2402] Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/remake/remake_git.bb')
-rw-r--r--meta/recipes-devtools/remake/remake_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/remake/remake_git.bb b/meta/recipes-devtools/remake/remake_git.bb
new file mode 100644
index 0000000000..7e9857e972
--- /dev/null
+++ b/meta/recipes-devtools/remake/remake_git.bb
@@ -0,0 +1,25 @@
+PR = "r0"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
+ file://tests/COPYING;md5=d32239bcb673463ab874e80d47fae504 \
+ file://glob/COPYING.LIB;md5=4a770b67e6be0f60da244beb2de0fce4"
+require remake.inc
+
+SRC_URI += "file://version-remake.texi.patch"
+SRCREV = "414d6e84121c6740ff5079370c905dea0f0e1ddb"
+S = "${WORKDIR}/git"
+
+DEPENDS += "readline"
+PROVIDES += "make"
+
+do_configure_prepend() {
+ # create config.rpath which required by configure.ac
+ autopoint || touch config.rpath
+}
+
+do_compile_prepend() {
+ # updating .po and other gnu build files
+ make update
+}
+
+BBCLASSEXTEND = "native"