aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/quilt/quilt
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2011-02-01 15:37:54 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-01 14:55:18 +0000
commitbc31351f6989372c7feb403f23532afd1f510fb1 (patch)
tree3b07cac7566db889b7af6a4b754a9dd934b6605e /meta/recipes-devtools/quilt/quilt
parentd6f4d682c0d51e13418ea3ab2ad75793c5e00324 (diff)
downloadopenembedded-core-contrib-bc31351f6989372c7feb403f23532afd1f510fb1.tar.gz
quilt: fix patch version detection
Fixes [BUGID #690] Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/recipes-devtools/quilt/quilt')
-rw-r--r--meta/recipes-devtools/quilt/quilt/patch-version-detection.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/quilt/quilt/patch-version-detection.patch b/meta/recipes-devtools/quilt/quilt/patch-version-detection.patch
new file mode 100644
index 0000000000..8b84f812b5
--- /dev/null
+++ b/meta/recipes-devtools/quilt/quilt/patch-version-detection.patch
@@ -0,0 +1,29 @@
+From: Jean Delvare
+Subject: [Quilt-dev] [PACH] Fix patch version detection
+Date: Mon, 21 Jun 2010 13:49:50 +0200
+
+New versions of GNU patch present themselves as "GNU patch" instead
+of just "patch".
+---
+ configure.ac | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -262,7 +262,11 @@ fi
+ AC_MSG_CHECKING([the version of $PATCH])
+ if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
+ set -- `$PATCH --version 2> /dev/null`
+- patch_version=$2
++ if test x$1 = xGNU ; then
++ patch_version=$3
++ else
++ patch_version=$2
++ fi
+ AC_MSG_RESULT($patch_version)
+ saved_IFS=$IFS; IFS='.'
+ set -- $patch_version
+
+--
+Jean Delvare
+Suse L3