aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/quilt/quilt/gnu_patch_test_fix_target.patch
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2011-04-13 17:22:49 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-28 10:44:20 +0100
commit07a6bec75c59fec06d0947ada708482900bf067a (patch)
treefe8ecf6a82a4b9ee81b4cea8cf80dae4dae666d1 /meta/recipes-devtools/quilt/quilt/gnu_patch_test_fix_target.patch
parent181d5f550d06aaf76ba20666664895355ba6ccea (diff)
downloadopenembedded-core-contrib-07a6bec75c59fec06d0947ada708482900bf067a.tar.gz
quilt: fix test for target build
fixes [YOCTO #969] (From OE-Core rev: fd2485ab15ed82cb3dc84b8408e516a932de1bd1) Signed-off-by: Qing He <qing.he@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/quilt/quilt/gnu_patch_test_fix_target.patch')
-rw-r--r--meta/recipes-devtools/quilt/quilt/gnu_patch_test_fix_target.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/quilt/quilt/gnu_patch_test_fix_target.patch b/meta/recipes-devtools/quilt/quilt/gnu_patch_test_fix_target.patch
new file mode 100644
index 0000000000..672155bb65
--- /dev/null
+++ b/meta/recipes-devtools/quilt/quilt/gnu_patch_test_fix_target.patch
@@ -0,0 +1,26 @@
+Upstream-Status: Pending
+
+the test should be skipped for cross compiling.
+
+Signed-off-by: Qing He <qing.he@intel.com>
+
+diff --git a/configure.ac b/configure.ac
+index 026a36c..8af591b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -245,6 +245,7 @@ fi
+ QUILT_COMPAT_PROG_PATH(DIFF, diff)
+ QUILT_COMPAT_PROG_PATH(PATCH, patch)
+
++if test "x$cross_compiling" != "xyes"; then
+ # Sun diff and others will not work because GNU patch options are used.
+ AC_MSG_CHECKING([the version of $DIFF])
+ if $DIFF --version 2>/dev/null | grep GNU >/dev/null; then
+@@ -293,6 +294,7 @@ current version of patch from ftp.gnu.org, or if you already have GNU patch
+ then you can supply its path with the '--with-patch=' option.
+ ])
+ fi
++fi
+
+ QUILT_COMPAT_PROG_PATH(FIND, find)
+