aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-06-11 11:44:33 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-15 11:09:40 +0100
commitb52a9d108d72ebdf93f2dc51aa6f26ccc890d451 (patch)
treecb53e96a9835a4caf335de82e435306dc8e575fa /meta/recipes-devtools/qemu
parent8befb09eb28bb6d8884d2052cd63c2c319eceed1 (diff)
downloadopenembedded-core-contrib-b52a9d108d72ebdf93f2dc51aa6f26ccc890d451.tar.gz
qemu: don't inherit autotools
qemu doesn't use autotools, so don't inherit it and just call 'make install' directly. No need to alter makefiles anymore, as they appear to respect CFLAGS now. Remove a chmod of beginend_funcs.sh (a file we patched in, and removed, many years ago). Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/qemu')
-rw-r--r--meta/recipes-devtools/qemu/qemu.inc15
1 files changed, 6 insertions, 9 deletions
diff --git a/meta/recipes-devtools/qemu/qemu.inc b/meta/recipes-devtools/qemu/qemu.inc
index faaea781cd..094a975177 100644
--- a/meta/recipes-devtools/qemu/qemu.inc
+++ b/meta/recipes-devtools/qemu/qemu.inc
@@ -5,7 +5,7 @@ DEPENDS = "glib-2.0 zlib pixman"
RDEPENDS_${PN}_class-target += "bash"
require qemu-targets.inc
-inherit autotools pkgconfig bluetooth
+inherit pkgconfig bluetooth
BBCLASSEXTEND = "native nativesdk"
# QEMU_TARGETS is overridable variable
@@ -27,6 +27,7 @@ EXTRA_OECONF = " \
--disable-werror \
--target-list=${@get_qemu_target_list(d)} \
--extra-cflags='${CFLAGS}' \
+ ${PACKAGECONFIG_CONFARGS} \
"
EXTRA_OECONF_append_class-native = " --python=python2.7"
@@ -36,27 +37,23 @@ LDFLAGS_append_class-native = " -fuse-ld=bfd"
export LIBTOOL="${HOST_SYS}-libtool"
+B = "${WORKDIR}/build"
+
do_configure_prepend_class-native() {
# Append build host pkg-config paths for native target since the host may provide sdl
BHOST_PKGCONFIG_PATH=$(PATH=/usr/bin:/bin pkg-config --variable pc_path pkg-config || echo "")
if [ ! -z "$BHOST_PKGCONFIG_PATH" ]; then
export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:$BHOST_PKGCONFIG_PATH
fi
-
- # Alter target makefiles to accept CFLAGS set via env
- sed -i -r \
- -e 's/^(C|OP_C|HELPER_C)FLAGS=/\1FLAGS+=/' \
- "${S}"/Makefile "${S}"/Makefile.target
}
do_configure() {
${S}/configure ${EXTRA_OECONF}
- test ! -e ${S}/target-i386/beginend_funcs.sh || chmod a+x ${S}/target-i386/beginend_funcs.sh
}
do_install () {
- export STRIP="true"
- autotools_do_install
+ export STRIP=""
+ oe_runmake 'DESTDIR=${D}' install
}
# The following fragment will create a wrapper for qemu-mips user emulation