summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-10-14 15:08:59 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-04 13:31:27 +0000
commit05151064eb2c0907ebb815c9ae3481a912835b39 (patch)
treec27fc486a38f17dbb4fd9273498dd5dee3671493 /meta/recipes-devtools/qemu
parent9d98e881de9030d80e451519b054681d4e9d2621 (diff)
downloadopenembedded-core-contrib-05151064eb2c0907ebb815c9ae3481a912835b39.tar.gz
qemu-helper-native: pass compiler flags
Pass all of the compiler and linker flags so the build is correctly configured. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/qemu')
-rw-r--r--meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb b/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb
index d9d9da0fad..372eebd886 100644
--- a/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb
+++ b/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb
@@ -12,7 +12,7 @@ S = "${WORKDIR}"
inherit native
do_compile() {
- ${CC} tunctl.c -o tunctl
+ ${CC} ${CFLAGS} ${LDFLAGS} -Wall tunctl.c -o tunctl
}
do_install() {