aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu_3.0.0.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2019-10-05 21:30:56 -0700
committerArmin Kuster <akuster808@gmail.com>2019-10-06 19:52:52 -0700
commit5b5ca76cc5dd424248c7e687e562597a2c85df57 (patch)
treec5cea3a4b87ef7473258c05bf3900fcb629b363d /meta/recipes-devtools/qemu/qemu_3.0.0.bb
parentc901bc8cd9de5853185af2059c6f1efeb4ccdd60 (diff)
downloadopenembedded-core-contrib-5b5ca76cc5dd424248c7e687e562597a2c85df57.tar.gz
qemu: fix build issue on new hosts with glibc 2.30
This fixes the following error: TOPDIR/tmp/work/x86_64-linux/qemu-native/3.1.0-r0/qemu-3.1.0/linux-user/syscall.c:254:16: error: static declaration of ‘gettid’ follows non-static declaration 254 | _syscall0(int, gettid) | ^~~~~~ TOPDIR/tmp/work/x86_64-linux/qemu-native/3.1.0-r0/qemu-3.1.0/linux-user/syscall.c:185:13: note: in definition of macro ‘_syscall0’ 185 | static type name (void) \ | ^~~~ In file included from /usr/include/unistd.h:1170, from TOPDIR/tmp/work/x86_64-linux/qemu-native/3.1.0-r0/qemu-3.1.0/include/qemu/osdep.h:90, from TOPDIR/tmp/work/x86_64-linux/qemu-native/3.1.0-r0/qemu-3.1.0/linux-user/syscall.c:20: /usr/include/bits/unistd_ext.h:34:16: note: previous declaration of ‘gettid’ was here 34 | extern __pid_t gettid (void) __THROW; | ^~~~~~ Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu_3.0.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu_3.0.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_3.0.0.bb b/meta/recipes-devtools/qemu/qemu_3.0.0.bb
index 6c3049b40e..e483acab55 100644
--- a/meta/recipes-devtools/qemu/qemu_3.0.0.bb
+++ b/meta/recipes-devtools/qemu/qemu_3.0.0.bb
@@ -40,6 +40,8 @@ SRC_URI = "https://download.qemu.org/${BPN}-${PV}.tar.xz \
file://CVE-2019-3812.patch \
file://CVE-2019-6778.patch \
file://CVE-2019-8934.patch \
+ file://0001-linux-user-assume-__NR_gettid-always-exists.patch \
+ file://0001-linux-user-rename-gettid-to-sys_gettid-to-avoid-clas.patch \
"
UPSTREAM_CHECK_REGEX = "qemu-(?P<pver>\d+(\.\d+)+)\.tar"