summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu-system-native_4.0.0.bb
diff options
context:
space:
mode:
authorAlistair Francis <Alistair.Francis@wdc.com>2019-05-02 04:09:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-02 13:42:56 +0100
commitfed2a0f37a76732cd3de1b127d6902fb16dd4e05 (patch)
treef78234452605c8cdc7fa95327e385342650e568b /meta/recipes-devtools/qemu/qemu-system-native_4.0.0.bb
parentde1782b23f8a98df3b42cb57bbcdff690bfa2343 (diff)
downloadopenembedded-core-contrib-fed2a0f37a76732cd3de1b127d6902fb16dd4e05.tar.gz
qemu: Upgrade from 3.1.0 to 4.0.0
This commit upgrade QEMU to the latest 4.0.0 release. - The COPYING.LIB file has changed SHA to: "Synchronize the LGPL 2.1 with the version from gnu.org" - SDL 1.2 has been removed, along with the --with-sdlabi command line arg - The backported patches have been removed - Al the other patches have been refreshed and the numbering has been updated Signed-off-by: Alistair Francis <alistair.francis@wdc.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-system-native_4.0.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu-system-native_4.0.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-system-native_4.0.0.bb b/meta/recipes-devtools/qemu/qemu-system-native_4.0.0.bb
new file mode 100644
index 0000000000..820883df65
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu-system-native_4.0.0.bb
@@ -0,0 +1,24 @@
+BPN = "qemu"
+
+require qemu-native.inc
+
+# As some of the files installed by qemu-native and qemu-system-native
+# are the same, we depend on qemu-native to get the full installation set
+# and avoid file clashes
+DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native"
+
+EXTRA_OECONF_append = " --target-list=${@get_qemu_system_target_list(d)}"
+
+PACKAGECONFIG ??= "fdt alsa kvm"
+
+# Handle distros such as CentOS 5 32-bit that do not have kvm support
+PACKAGECONFIG_remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
+
+do_install_append() {
+ install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
+
+ # The following is also installed by qemu-native
+ rm -f ${D}${datadir}/qemu/trace-events-all
+ rm -rf ${D}${datadir}/qemu/keymaps
+ rm -rf ${D}${datadir}/icons/
+}