aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorJingdong Lu <jingdong.lu@windriver.com>2011-01-19 17:04:43 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-20 21:37:02 +0000
commite261c1760d8a660c13cd00039a4812d51f47f3df (patch)
treea4d4e071a2b465cd08bdbdc1cfc3e8a5b47e6f85 /meta/recipes-devtools/python
parent426de6589b4b94769446e655999b68d0ab1f046b (diff)
downloadopenembedded-core-contrib-e261c1760d8a660c13cd00039a4812d51f47f3df.tar.gz
python: Fix failures of LSB python-runtime tests.
Fix failues of LSB python-runtime tests. test_largefile: add "ac_cv_sizeof_off_t=8" option explicitly into configure options in order to enable "LFS". test_codecs, test_re, test_unicode: "--with-wctype-functions" will cause these tests failed, so remove it for LSB. test_builtin, test_getargs: "sitecustomize.py" cause default encoding changed from "ascii" into "utf8" and it will cause these tests failed, so remove this file for LSB. Signed-off-by: Jingdong Lu<jingdong.lu@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python.inc10
-rw-r--r--meta/recipes-devtools/python/python_2.6.6.bb11
2 files changed, 18 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python.inc b/meta/recipes-devtools/python/python.inc
index 62a6ba1589..f78250769b 100644
--- a/meta/recipes-devtools/python/python.inc
+++ b/meta/recipes-devtools/python/python.inc
@@ -22,4 +22,14 @@ EXTRA_OECONF = "\
--enable-shared \
"
+EXTRA_OECONF_poky-lsb = "\
+ --with-threads \
+ --with-pymalloc \
+ --with-cyclic-gc \
+ --without-cxx \
+ --with-signal-module \
+ --enable-shared \
+ ac_cv_sizeof_off_t=8 \
+"
+
PARALLEL_MAKE = ""
diff --git a/meta/recipes-devtools/python/python_2.6.6.bb b/meta/recipes-devtools/python/python_2.6.6.bb
index b33e0a9e87..ad0d7a956a 100644
--- a/meta/recipes-devtools/python/python_2.6.6.bb
+++ b/meta/recipes-devtools/python/python_2.6.6.bb
@@ -1,8 +1,11 @@
require python.inc
DEPENDS = "python-native db gdbm openssl readline sqlite3 zlib"
DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
LIC_FILES_CHKSUM = "file://LICENSE;md5=38fdd546420fab09ac6bd3d8a1c83eb6"
+
+DISTRO_SRC_URI ?= "file://sitecustomize.py"
+DISTRO_SRC_URI_poky-lsb = ""
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
file://01-use-proper-tools-for-cross-build.patch \
@@ -12,7 +15,7 @@ SRC_URI = "\
file://05-enable-ctypes-cross-build.patch \
file://06-avoid_usr_lib_termcap_path_in_linking.patch \
file://99-ignore-optimization-flag.patch \
- file://sitecustomize.py \
+ ${DISTRO_SRC_URI} \
"
SRC_URI[md5sum] = "cf4e6881bb84a7ce6089e4a307f71f14"
@@ -74,7 +77,9 @@ do_install() {
BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
DESTDIR=${D} LIBDIR=${libdir} install
- install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}
+ if [ -e ${WORKDIR}/sitecustomize.py ]; then
+ install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}
+ fi
# remove hardcoded ccache, see http://bugs.openembedded.net/show_bug.cgi?id=4144
sed -i -e s,ccache,'$(CCACHE)', ${D}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile