aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-04-15 18:54:04 -0700
committerSaul Wold <sgw@linux.intel.com>2011-04-22 22:03:59 -0700
commit8f6436b25a96594d09c64c7ba20a045cb1f8d18a (patch)
tree2ca85f3d3f85bb417df8c2342c786ad511ca126a /meta/recipes-devtools/python
parent7e2c5d976d05c873ca949504e8c2416a34ac7f97 (diff)
downloadopenembedded-core-contrib-8f6436b25a96594d09c64c7ba20a045cb1f8d18a.tar.gz
python-pycairo: fix installation path of __init__.py
This fixes Bug [YOCTO #477] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python-pycairo_1.8.10.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-pycairo_1.8.10.bb b/meta/recipes-devtools/python/python-pycairo_1.8.10.bb
index 7d73dc2ec4..24b3ff2c43 100644
--- a/meta/recipes-devtools/python/python-pycairo_1.8.10.bb
+++ b/meta/recipes-devtools/python/python-pycairo_1.8.10.bb
@@ -6,7 +6,7 @@ LICENSE = "LGPLv2.1 & MPLv1.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=f2e071ab72978431b294a0d696327421"
# cairo >= 1.8.8
DEPENDS = "cairo"
-PR = "ml0"
+PR = "r1"
SRC_URI = "http://cairographics.org/releases/py2cairo-${PV}.tar.gz"
@@ -16,6 +16,12 @@ S = "${WORKDIR}/pycairo-${PV}"
inherit distutils pkgconfig
+do_compile_prepend() {
+#fix the installation path of __init__.py
+#It was going in the sysroot instead of target install location
+ sed -i -e "s#dsy.get_python_lib()#'${D}${PYTHON_SITEPACKAGES_DIR}'#" ${S}/setup.py
+}
+
do_install_append () {
install -d ${D}${includedir}
install -d ${D}${libdir}