aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorMichael Lippautz <michael.lippautz@gmail.com>2011-05-11 10:40:17 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-11 16:44:52 +0100
commit58f8eb15eea892b2694478bbc71e8c907014509b (patch)
tree11e5a4dc97fba24de8eb1e2e3126ea7a34c6c507 /meta/recipes-devtools/python
parent69bf813c12d1a00c4f3cc329f7b459773ea835b3 (diff)
downloadopenembedded-core-contrib-58f8eb15eea892b2694478bbc71e8c907014509b.tar.gz
python-native: Add ctypes patch to native build (as in cross-compilation)
This fix makes ctypes build for python-native which may be needed by extensions that utilize ctypes and use setuptools/distutils as their build system. Tested building pyudev for beagleboard target using Ângstrom distro. Signed-off-by: Michael Lippautz <michael.lippautz@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python-native_2.6.6.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.6.6.bb b/meta/recipes-devtools/python/python-native_2.6.6.bb
index 11956a400e..0f9ae10e5a 100644
--- a/meta/recipes-devtools/python/python-native_2.6.6.bb
+++ b/meta/recipes-devtools/python/python-native_2.6.6.bb
@@ -1,12 +1,13 @@
require python.inc
DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
LIC_FILES_CHKSUM = "file://LICENSE;md5=38fdd546420fab09ac6bd3d8a1c83eb6"
SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
file://04-default-is-optimized.patch \
file://05-enable-ctypes-cross-build.patch \
+ file://06-ctypes-libffi-fix-configure.patch \
file://10-distutils-fix-swig-parameter.patch \
file://11-distutils-never-modify-shebang-line.patch \
file://12-distutils-prefix-is-inside-staging-area.patch \
@@ -27,6 +28,10 @@ EXTRA_OEMAKE = '\
STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
'
+do_configure_prepend() {
+ autoreconf --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || bbnote "_ctypes failed to autoreconf"
+}
+
do_install() {
oe_runmake 'DESTDIR=${D}' install
install -d ${D}${bindir}/