aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-01-20 16:49:59 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-22 23:42:37 +0000
commit4583cd1bb15306e8f0ab7bcd80732e6f35aa4533 (patch)
tree55ee56e0237965586c57a0f34d279f6b9522409f /meta/recipes-devtools/python
parent046b1f4cf439e36c8e8a4904f8e8014a9ea733e2 (diff)
downloadopenembedded-core-contrib-4583cd1bb15306e8f0ab7bcd80732e6f35aa4533.tar.gz
python-native: Make python-native also RPROVIDE python-unittest-native
The python-nose upgrade to 1.3.7 required a new unittest runtime dependency after this, bitbake cant find a runtime provider for it when trying to build python-nose-native, this patch makes python-native RPROVIDES python-unittest-native to fix the issue. Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.11.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.11.bb b/meta/recipes-devtools/python/python-native_2.7.11.bb
index 34f5c2914e..4c204a4f0f 100644
--- a/meta/recipes-devtools/python/python-native_2.7.11.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.11.bb
@@ -25,7 +25,7 @@ FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:"
inherit native
-RPROVIDES += "python-distutils-native python-compression-native python-textutils-native python-codecs-native python-core-native"
+RPROVIDES += "python-distutils-native python-compression-native python-textutils-native python-codecs-native python-core-native python-unittest-native"
EXTRA_OECONF_append = " --bindir=${bindir}/${PN}"