summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-04-18 17:59:18 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-23 23:30:20 +0100
commit66ecad10aea3b8b1e66ecbb495be6142aa638371 (patch)
treeb36855a9ae88b4f07a0ecd1b70c76e4974e8fe03 /meta/recipes-devtools/python
parent1b74389d938c1dcf8f896d12e2ee01649df85193 (diff)
downloadopenembedded-core-contrib-66ecad10aea3b8b1e66ecbb495be6142aa638371.tar.gz
python3-pygobject: update to 3.32.0
Switch to meson build system. Add a patch to disable tests. Add "introspection" to unknown configure option whitelist, as this recipe needs g-i unconditionally. (From OE-Core rev: 890a460d2ad9bce8f6a1df055e040f334f958673) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-pygobject/0001-Do-not-build-tests.patch26
-rw-r--r--meta/recipes-devtools/python/python3-pygobject_3.32.0.bb (renamed from meta/recipes-devtools/python/python3-pygobject_3.28.3.bb)10
2 files changed, 33 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python3-pygobject/0001-Do-not-build-tests.patch b/meta/recipes-devtools/python/python3-pygobject/0001-Do-not-build-tests.patch
new file mode 100644
index 0000000000..626a82cb09
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pygobject/0001-Do-not-build-tests.patch
@@ -0,0 +1,26 @@
+From c125a806de951359ab7e302b0584f7c92fa451ad Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Fri, 12 Apr 2019 16:25:58 +0200
+Subject: [PATCH] Do not build tests
+
+They require installing tests from g-i, which we do not do.
+
+Upstream-Status: Inappropriate [oe-core specific]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index a63d771..b3925d0 100644
+--- a/meson.build
++++ b/meson.build
+@@ -174,4 +174,4 @@ configure_file(input : 'PKG-INFO.in',
+
+ subdir('gi')
+ subdir('pygtkcompat')
+-subdir('tests')
++#subdir('tests')
+--
+2.17.1
+
diff --git a/meta/recipes-devtools/python/python3-pygobject_3.28.3.bb b/meta/recipes-devtools/python/python3-pygobject_3.32.0.bb
index 313af227b6..c2676b3502 100644
--- a/meta/recipes-devtools/python/python3-pygobject_3.28.3.bb
+++ b/meta/recipes-devtools/python/python3-pygobject_3.32.0.bb
@@ -3,6 +3,7 @@ SECTION = "devel/python"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
+GNOMEBASEBUILDCLASS = "meson"
inherit gnomebase distutils3-base gobject-introspection upstream-version-is-even
DEPENDS += "python3 glib-2.0"
@@ -10,10 +11,13 @@ DEPENDS += "python3 glib-2.0"
SRCNAME="pygobject"
SRC_URI = " \
http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
+ file://0001-Do-not-build-tests.patch \
"
-SRC_URI[md5sum] = "3bac63c86bb963aa401f97859464aa90"
-SRC_URI[sha256sum] = "3dd3e21015d06e00482ea665fc1733b77e754a6ab656a5db5d7f7bfaf31ad0b0"
+UNKNOWN_CONFIGURE_WHITELIST = "introspection"
+
+SRC_URI[md5sum] = "6e39bca1d19a27cde4435061dd59578a"
+SRC_URI[sha256sum] = "83f4d7e59fde6bc6b0d39c5e5208574802f759bc525a4cb8e7265dfcba45ef29"
S = "${WORKDIR}/${SRCNAME}-${PV}"
@@ -21,7 +25,7 @@ PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wa
# python3-pycairo is checked on configuration -> DEPENDS
# we don't link against python3-pycairo -> RDEPENDS
-PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo python3-pycairo, python3-pycairo"
+PACKAGECONFIG[cairo] = "-Dpycairo=true,-Dpycairo=false, cairo python3-pycairo, python3-pycairo"
RDEPENDS_${PN} += "python3-setuptools"