aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2015-11-24 16:43:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-01 21:30:57 +0000
commitd4723c609f700180ee808ac3fbbe2225043a8353 (patch)
treee133b5760a13b93d60305a8ede9f8813a9f49a2e /meta/recipes-devtools/python
parent701ec1977ced1bb08461e6de98b4f63d21cba8a6 (diff)
downloadopenembedded-core-contrib-d4723c609f700180ee808ac3fbbe2225043a8353.tar.gz
python3: fix building nativesdk-python3
When the class nativesdk.bbclass is inherited, it redefines TARGET_CC_ARCH, in the case of python3, this enables debug, causing an error while linking, since we dont enable debug during configure theres no declaration of some functions, this patch makes sure we keep debug disabled, fixing the linking errors. [YOCTO #8467] Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3_3.5.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.0.bb b/meta/recipes-devtools/python/python3_3.5.0.bb
index d0872be2b6..2475dba1fc 100644
--- a/meta/recipes-devtools/python/python3_3.5.0.bb
+++ b/meta/recipes-devtools/python/python3_3.5.0.bb
@@ -58,6 +58,7 @@ CACHED_CONFIGUREVARS = "ac_cv_have_chflags=no \
"
TARGET_CC_ARCH += "-DNDEBUG -fno-inline"
+SDK_CC_ARCH += "-DNDEBUG -fno-inline"
EXTRA_OEMAKE += "CROSS_COMPILE=yes"
EXTRA_OECONF += "CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/ --without-ensurepip"