summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-06-17 13:48:20 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-06-21 18:44:23 +0100
commitefac044cabdbe77556a0b9903595fd602f39ac8d (patch)
tree371d95e57aaf35697c12a84f33c1b1dac36b19ee /meta/recipes-devtools/python
parent98cc5639d74dc71aa1352b50f97ed832245d3c3b (diff)
downloadopenembedded-core-contrib-efac044cabdbe77556a0b9903595fd602f39ac8d.tar.gz
python3: fix a race condition in the test_socket.testSockName test
This test uses find_unused_port() which is inherently racey, so retry it a few times before failing. [ YOCTO #14840 ] Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3/0001-Mitigate-the-race-condition-in-testSockName.patch47
-rw-r--r--meta/recipes-devtools/python/python3_3.10.5.bb1
2 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3/0001-Mitigate-the-race-condition-in-testSockName.patch b/meta/recipes-devtools/python/python3/0001-Mitigate-the-race-condition-in-testSockName.patch
new file mode 100644
index 0000000000..e19df08f87
--- /dev/null
+++ b/meta/recipes-devtools/python/python3/0001-Mitigate-the-race-condition-in-testSockName.patch
@@ -0,0 +1,47 @@
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@arm.com>
+
+From 8103b90148e8768456c3ab707de105d63d9d5b20 Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@arm.com>
+Date: Fri, 17 Jun 2022 11:53:59 +0100
+Subject: [PATCH] Mitigate the race condition in testSockName
+
+find_unused_port() has an inherent race condition, but we can't use
+bind_port() as that uses .getsockname() which this test is exercising.
+
+Try binding to unused ports a few times before failing.
+---
+ Lib/test/test_socket.py | 15 +++++++++++++--
+ 1 file changed, 13 insertions(+), 2 deletions(-)
+
+diff --git a/Lib/test/test_socket.py b/Lib/test/test_socket.py
+index c981903824..b1630d18b6 100644
+--- a/Lib/test/test_socket.py
++++ b/Lib/test/test_socket.py
+@@ -1390,10 +1390,21 @@ def testStringToIPv6(self):
+
+ def testSockName(self):
+ # Testing getsockname()
+- port = socket_helper.find_unused_port()
+ sock = socket.socket(socket.AF_INET, socket.SOCK_STREAM)
+ self.addCleanup(sock.close)
+- sock.bind(("0.0.0.0", port))
++
++ # Since find_unused_port() is inherently subject to race conditions, we
++ # call it a couple times if necessary.
++ for i in itertools.count():
++ port = socket_helper.find_unused_port()
++ try:
++ sock.bind(("0.0.0.0", port))
++ except OSError as e:
++ if e.errno != errno.EADDRINUSE or i == 5:
++ raise
++ else:
++ break
++
+ name = sock.getsockname()
+ # XXX(nnorwitz): http://tinyurl.com/os5jz seems to indicate
+ # it reasonable to get the host's addr in addition to 0.0.0.0.
+--
+2.25.1
+
diff --git a/meta/recipes-devtools/python/python3_3.10.5.bb b/meta/recipes-devtools/python/python3_3.10.5.bb
index bf5930c96f..599a1884b4 100644
--- a/meta/recipes-devtools/python/python3_3.10.5.bb
+++ b/meta/recipes-devtools/python/python3_3.10.5.bb
@@ -35,6 +35,7 @@ SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
file://0001-setup.py-Do-not-detect-multiarch-paths-when-cross-co.patch \
file://deterministic_imports.patch \
file://0001-Avoid-shebang-overflow-on-python-config.py.patch \
+ file://0001-Mitigate-the-race-condition-in-testSockName.patch \
"
SRC_URI:append:class-native = " \