summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-08 18:18:59 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-10 14:12:54 +0000
commitb0fdf0688109ba6b87840a0837bebee3d9a27089 (patch)
treedf99f848c34a706d9cb653c7f63da4ace01a0ba0 /meta/recipes-devtools/python
parentdfde9526f9183907b2bc47fde4f59ab3a5848d90 (diff)
downloadopenembedded-core-contrib-b0fdf0688109ba6b87840a0837bebee3d9a27089.tar.gz
python3-pyyaml: enable ptest
Upstream is in the process of migrating testing to pytest, backport test_dump_load.py (the legacy_tests were throwing Errors and Failures). We don't really need to run upstream's test suite, but we do need to verify that our runtime is functional. https://github.com/yaml/pyyaml/commit/a98fd6088e81d7aca571220c966bbfe2ac43c335 Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-pyyaml/run-ptest3
-rw-r--r--meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb17
2 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pyyaml/run-ptest b/meta/recipes-devtools/python/python3-pyyaml/run-ptest
new file mode 100644
index 0000000000..8d2017d39c
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pyyaml/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest --automake
diff --git a/meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb b/meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb
index 102e2f2498..62be059df5 100644
--- a/meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb
+++ b/meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb
@@ -20,4 +20,21 @@ RDEPENDS:${PN} += "\
${PYTHON_PN}-netclient \
"
+inherit ptest
+SRC_URI += "\
+ https://raw.githubusercontent.com/yaml/pyyaml/a98fd6088e81d7aca571220c966bbfe2ac43c335/tests/test_dump_load.py;name=test \
+ file://run-ptest \
+"
+SRC_URI[test.sha256sum] = "b6a8a2825d89fdc8aee226560f66b8196e872012a0ea7118cbef1a832359434a"
+
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-unittest-automake-output \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${WORKDIR}/test_dump_load.py ${D}${PTEST_PATH}/tests/
+}
+
BBCLASSEXTEND = "native nativesdk"