summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-02-28 15:32:48 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-29 10:26:14 +0000
commit91dd6f2878bcdbb6f9ba65927f6c6f981b0b3f1a (patch)
tree49afe0cb599b7edbaf6626f8d0efaf043b459b0a /meta/recipes-devtools/python
parent0174e7c4d1f3d3a7458d357b0d7be63b5d748572 (diff)
downloadopenembedded-core-contrib-91dd6f2878bcdbb6f9ba65927f6c6f981b0b3f1a.tar.gz
python3-typing-extensions: upgrade 4.9.0 -> 4.10.0
Changelog: ============ -Add support for PEP 728, supporting the closed keyword argument and the special __extra_items__ key for TypedDict. -Add support for PEP 742, adding typing_extensions.TypeIs. -Drop runtime error when a read-only TypedDict item overrides a mutable one. Type checkers should still flag this as an error. -Speedup issubclass() checks against simple runtime-checkable protocols by around 6% (backporting python/cpython#112717 -Fix a regression in the implementation of protocols where typing.Protocol classes that were not marked as @runtime_checkable would be unnecessarily introspected, potentially causing exceptions to be raised if the protocol had problematic members. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-typing-extensions_4.10.0.bb (renamed from meta/recipes-devtools/python/python3-typing-extensions_4.9.0.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-typing-extensions_4.9.0.bb b/meta/recipes-devtools/python/python3-typing-extensions_4.10.0.bb
index 3553c597ac..8698a80cc5 100644
--- a/meta/recipes-devtools/python/python3-typing-extensions_4.9.0.bb
+++ b/meta/recipes-devtools/python/python3-typing-extensions_4.10.0.bb
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=fcf6b249c2641540219a727f35d8d2c2"
# The name on PyPi is slightly different.
PYPI_PACKAGE = "typing_extensions"
-SRC_URI[sha256sum] = "23478f88c37f27d76ac8aee6c905017a143b0b1b886c3c9f66bc2fd94f9f5783"
+SRC_URI[sha256sum] = "b0abd7c89e8fb96f98db18d86106ff1d90ab692004eb746cf6eda2682f91b3cb"
inherit pypi python_flit_core