summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2022-05-17 18:22:14 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-05-20 19:08:20 +0100
commit7fdfa8504dcc9c15e957256c97b43eec5291216c (patch)
tree9ce50d02d4f7d1b69489b186007120929e8251c3 /meta/recipes-devtools/python
parentb6c1e37ed20f636f4f3cdfcef204ea4c072dde58 (diff)
downloadopenembedded-core-contrib-7fdfa8504dcc9c15e957256c97b43eec5291216c.tar.gz
python3-cryptography: remove --benchmark-disable option
The new version introduced below change, so remove the option to avoid python3-pytest-benchmark rdepends to fix the gap. 496703c8 Refs #7079 -- added basic scaffholding for benchmarks (#7087) Fixes: # ./run-ptest Free memory: 31.283 GB ERROR: usage: pytest [options] [file_or_dir] [file_or_dir] [...] pytest: error: unrecognized arguments: --benchmark-disable inifile: /usr/lib/python3-cryptography/ptest/pyproject.toml rootdir: /usr/lib/python3-cryptography/ptest Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-cryptography/0001-pyproject.toml-remove-benchmark-disable-option.patch40
-rw-r--r--meta/recipes-devtools/python/python3-cryptography_37.0.1.bb1
2 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-cryptography/0001-pyproject.toml-remove-benchmark-disable-option.patch b/meta/recipes-devtools/python/python3-cryptography/0001-pyproject.toml-remove-benchmark-disable-option.patch
new file mode 100644
index 0000000000..481f595246
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-cryptography/0001-pyproject.toml-remove-benchmark-disable-option.patch
@@ -0,0 +1,40 @@
+From ce972ea92d724f232323a9a6265a8b44d913d4d8 Mon Sep 17 00:00:00 2001
+From: Mingli Yu <mingli.yu@windriver.com>
+Date: Tue, 17 May 2022 17:22:48 +0800
+Subject: [PATCH] pyproject.toml: remove --benchmark-disable option
+
+The new version introduced below change, so remove the option
+to avoid python3-pytest-benchmark rdepends to fix the gap.
+496703c8 Refs #7079 -- added basic scaffholding for benchmarks (#7087)
+
+Fixes:
+ # ./run-ptest
+ Free memory: 31.283 GB
+ ERROR: usage: pytest [options] [file_or_dir] [file_or_dir] [...]
+ pytest: error: unrecognized arguments: --benchmark-disable
+ inifile: /usr/lib/python3-cryptography/ptest/pyproject.toml
+ rootdir: /usr/lib/python3-cryptography/ptest
+
+Upstream-Status: Inappropriate [OE specific]
+
+Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
+---
+ pyproject.toml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 4d58129..b011fca 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -15,7 +15,7 @@ line-length = 79
+ target-version = ["py36"]
+
+ [tool.pytest.ini_options]
+-addopts = "-r s --capture=no --strict-markers --benchmark-disable"
++addopts = "-r s --capture=no --strict-markers"
+ markers = [
+ "skip_fips: this test is not executed in FIPS mode",
+ "supported: parametrized test requiring only_if and skip_message",
+--
+2.25.1
+
diff --git a/meta/recipes-devtools/python/python3-cryptography_37.0.1.bb b/meta/recipes-devtools/python/python3-cryptography_37.0.1.bb
index 1271954a08..191ea29b9c 100644
--- a/meta/recipes-devtools/python/python3-cryptography_37.0.1.bb
+++ b/meta/recipes-devtools/python/python3-cryptography_37.0.1.bb
@@ -15,6 +15,7 @@ SRC_URI += "file://run-ptest \
file://check-memfree.py \
file://0001-Cargo.toml-specify-pem-version.patch \
file://0002-Cargo.toml-edition-2018-2021.patch \
+ file://0001-pyproject.toml-remove-benchmark-disable-option.patch \
crate://crates.io/Inflector/0.11.4 \
crate://crates.io/aliasable/0.1.3 \
crate://crates.io/asn1/0.8.7 \