summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-07-13 17:28:16 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-07-14 23:20:56 +0100
commit825176ea8130a50cce221678f6fcba25ac956950 (patch)
tree1f28f1197ae7ce918c043180c29d1bef29942f89 /meta/recipes-devtools/python
parente902578c2c9aacdc83dcfa517bc1e57667fcc460 (diff)
downloadopenembedded-core-contrib-825176ea8130a50cce221678f6fcba25ac956950.tar.gz
python3-installer: bootstrap by installing installer with installer
The installer can install itself by simply adding src/ to PYTHONPATH. As this previously used unzip, we need to disable bytecode as otherwise the newly packaged .pyc files conflict with the any generated .pyc files in the sysroot. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-installer_0.5.1.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python3-installer_0.5.1.bb b/meta/recipes-devtools/python/python3-installer_0.5.1.bb
index f4f9e1bde6..b7780702d6 100644
--- a/meta/recipes-devtools/python/python3-installer_0.5.1.bb
+++ b/meta/recipes-devtools/python/python3-installer_0.5.1.bb
@@ -12,11 +12,13 @@ SRC_URI[sha256sum] = "f970995ec2bb815e2fdaf7977b26b2091e1e386f0f42eafd5ac811953d
inherit pypi python_flit_core
+# Bootstrap the native install by installing with ourself
DEPENDS:remove:class-native = "python3-installer-native"
-DEPENDS:append:class-native = " unzip-native"
-do_install:class-native () {
- python_pep517_do_bootstrap_install
+INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"
+
+do_install:prepend:class-native() {
+ export PYTHONPATH="${S}/src"
}
BBCLASSEXTEND = "native nativesdk"