summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorHugues Kamba <Hugues.Kamba@arm.com>2018-10-30 09:37:25 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-06 12:14:05 +0000
commiteffa141bfce55aab25142ee578c95383c755ad73 (patch)
treed5edc2e8a7dd2646a2c12bc86d2c7f7103724f16 /meta/recipes-devtools/python
parente188a75aa882efc98b8390f43f18279c3707314a (diff)
downloadopenembedded-core-contrib-effa141bfce55aab25142ee578c95383c755ad73.tar.gz
python3: Fix python3-pyvenv run-time dependency
Pyvenv is just a small script that uses venv to create virtual environments. https://www.python.org/dev/peps/pep-0405/#creating-virtual-environments This patch adds the python3-venv module as a self-contained package which python3-pyvenv must depend on at run-time. The patch also provides the package python3-pyvenv from the pyhton3-venv package.This is good for future-proofing since python3-pyvenv has been deprecated and only python3-venv is now available in Python 3.6. https://docs.python.org/3/library/venv.html. Without this patch python3-pyvenv is broken because it is missing the venv module at run-time. This patch specifies the newly created python3-venv as a run-time dependency of python3-pyvenv. Signed-off-by: Hugues Kamba <hugues.kamba@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3/python3-manifest.json16
-rw-r--r--meta/recipes-devtools/python/python3_3.5.6.bb4
2 files changed, 18 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python3/python3-manifest.json b/meta/recipes-devtools/python/python3/python3-manifest.json
index f922561368..ef7fa4ecaf 100644
--- a/meta/recipes-devtools/python/python3/python3-manifest.json
+++ b/meta/recipes-devtools/python/python3/python3-manifest.json
@@ -1107,6 +1107,22 @@
"${libdir}/python${PYTHON_MAJMIN}/__pycache__/getpass.*.pyc"
]
},
+ "venv": {
+ "summary": "Provides support for creating lightweight virtual environments with their own site directories, optionally isolated from system site directories.",
+ "rdepends": [
+ "compression",
+ "core",
+ "logging",
+ "shell",
+ "stringold",
+ "unixadmin"
+ ],
+ "files": [
+ "${libdir}/python${PYTHON_MAJMIN}/venv",
+ "${bindir}/pyvenv*"
+ ],
+ "cached": []
+ },
"xml": {
"summary": "Python basic XML support",
"rdepends": [
diff --git a/meta/recipes-devtools/python/python3_3.5.6.bb b/meta/recipes-devtools/python/python3_3.5.6.bb
index 2a4547694a..31f8eada11 100644
--- a/meta/recipes-devtools/python/python3_3.5.6.bb
+++ b/meta/recipes-devtools/python/python3_3.5.6.bb
@@ -226,8 +226,8 @@ FILES_${PN}-2to3 += "${bindir}/2to3-${PYTHON_MAJMIN}"
FILES_${PN}-pydoc += "${bindir}/pydoc${PYTHON_MAJMIN} ${bindir}/pydoc3"
FILES_${PN}-idle += "${bindir}/idle3 ${bindir}/idle${PYTHON_MAJMIN}"
-PACKAGES =+ "${PN}-pyvenv"
-FILES_${PN}-pyvenv += "${bindir}/pyvenv-${PYTHON_MAJMIN} ${bindir}/pyvenv"
+# provide python-pyvenv from python3-venv
+RPROVIDES_${PN}-venv += "${PN}-pyvenv"
# package libpython3
PACKAGES =+ "libpython3 libpython3-staticdev"