summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.15.bb
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-10-23 13:22:18 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-07 10:54:21 +0000
commit96383efa2726ed1bf7893332d726112a8552fc24 (patch)
tree62c1a71e800ebc2bcecd29d535881af342d25f3b /meta/recipes-devtools/python/python_2.7.15.bb
parent0f87f8522a2c1b5a7042738887952b98060fbd9d (diff)
downloadopenembedded-core-contrib-96383efa2726ed1bf7893332d726112a8552fc24.tar.gz
python/python3: use cc_basename to replace CC for checking compiler
When working path contains "clang"/"gcc"/"icc", it might be part of $CC because of the "--sysroot" parameter. That could cause judgement error about clang/gcc/icc compilers. eg: if build under /yocto/builds/xicc/, bitbake python, $CC will contains xicc, will make $CC match *icc, but actuall xicc just folder name. When "*icc" is matched, below errors are reported when compiling python/python3: x86_64-wrs-linux-gcc: error: strict: No such file or directory x86_64-wrs-linux-gcc: error: unrecognized command line option '-fp-model' Here use cc_basename to replace CC for checking compiler to avoid such kind of issue. Signed-off-by: Li Zhou <li.zhou@windriver.com> Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.15.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.15.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.15.bb b/meta/recipes-devtools/python/python_2.7.15.bb
index 7a6da884e5..f462d08725 100644
--- a/meta/recipes-devtools/python/python_2.7.15.bb
+++ b/meta/recipes-devtools/python/python_2.7.15.bb
@@ -33,6 +33,7 @@ SRC_URI += "\
file://float-endian.patch \
file://0001-closes-bpo-34540-Convert-shutil._call_external_zip-t.patch \
file://0001-2.7-bpo-34623-Use-XML_SetHashSalt-in-_elementtree-GH.patch \
+ file://0001-python2-use-cc_basename-to-replace-CC-for-checking-c.patch \
"
S = "${WORKDIR}/Python-${PV}"